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Disclaimer of Warranty
Synopsys, Inc. makes no representations or warranties, either expressed or 
implied, by or with respect to anything in this manual, and shall not be liable 
for any implied warranties of merchantability or fitness for a particular 
purpose of for any indirect, special or consequential damages.

Copyright Notice
Copyright © 2011 Synopsys, Inc. All Rights Reserved.

Synopsys software products contain certain confidential information of 
Synopsys, Inc. Use of this copyright notice is precautionary and does not 
imply publication or disclosure. No part of this publication may be repro-
duced, transmitted, transcribed, stored in a retrieval system, or translated 
into any language in any form by any means without the prior written 
permission of Synopsys, Inc. While every precaution has been taken in the 
preparation of this book, Synopsys, Inc. assumes no responsibility for errors 
or omissions. This publication and the features described herein are subject 
to change without notice.

Trademarks

Registered Trademarks (®)
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Vera, and YIELDirector are registered trademarks of Synopsys, Inc.
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Magellan, Mars, Mars-Rail, Mars-Xtalk, Milkyway, ModelSource, Module 
Compiler, MultiPoint, Physical Analyst, Planet, Planet-PL, Polaris, Power 
Compiler, Raphael, Saturn, Scirocco, Scirocco-i, Star-RCXT, Star-SimXT, 
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Express, VCSi, VHDL Compiler, VirSim, and VMC are trademarks of 
Synopsys, Inc.

Service Marks (SM)
MAP-in, SVP Café, and TAP-in are service marks of Synopsys, Inc. 

SystemC is a trademark of the Open SystemC Initiative and is used under 
license. ARM and AMBA are registered trademarks of ARM Limited. Saber is a 
registered trademark of SabreMark Limited Partnership and is used under 
license. All other product or company names may be trademarks of their 
respective owners. 

Restricted Rights Legend
Government Users: Use, reproduction, release, modification, or disclosure of 
this commercial computer software, or of any related documentation of any 
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C H A P T E R  1

Getting Started

The Identify® Actel Edition tool set includes the Identify instrumentor and the 
Identify debugger. These two tools allow you to debug your HDL design:

• in the target system,

• at the target speed,

• at the VHDL/Verilog RTL source level.

The Identify tool set helps you debug any design that is implemented by an 
electronically programmable logic device such as an FPGA or PLD. For the 
first time you will be able to debug live hardware with the internal design 
visibility you need while using intuitive debugging techniques.

This guide provides comprehensive information about how the Identify tool 
set works within your HDL design flow.

This chapter contains:

• Manual Conventions

• Tool Conventions
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Manual Conventions
There are several conventions this manual uses in order to communicate 
command information.

Text Conventions
There are several text conventions that this manual uses to organize 
command, path, and directory information. These conventions or text styles 
are:

Syntax Conventions
There are several conventions that this manual uses to convey command 
syntax. These conventions are:

This convention... Organizes this information...

Bold command titles

Monospacing type command, path name, and directory examples

Sans-serif type commands, literals, and keywords

Italics variable arguments

This convention... Organizes this information...

bold Commands and literal arguments entered as shown.

italics User-defined arguments or example command 
information.

[ ] Optional information or arguments for command 
use. Do not use these brackets with the command 
within the command line.



Tool Conventions Chapter 1: Getting Started

Identify Actel Edition User Guide Copyright © 2011 Synopsys, Inc.
March 2011 11

Tool Conventions
There are tool concepts you must familiarize yourself with when using the 
Identify tool set. These concepts help you to decipher structural and 
HDL-related information. 

File System Conventions
The term file system refers to any command that uses file, directory, or path 
name information in its argument. A file system reference must follow these 
conventions: 

Path Separator “/”

All file system commands that contain a directory name use only forward 
slashes, regardless of the underlying operating system:

/usr/syn/data.dat

c:/synopsys/data.dat

... Items that can be repeated any number of times.

| Choices you can make between two items or 
commands. The items are located on either side of 
this symbol.

# Comments concerning the code or information 
within the command line.

This convention... Organizes this information...
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Wildcards

A wildcard is a command element you can use to represent many different 
files. You can use these wildcards as arguments to the file system commands. 
Conventions for wildcards are as follows: 

Square brackets are used in pattern matching as follows:

To use square brackets in wildcard specifications, you must delimit the entire 
name with curly braces { }. For example,

{[a-d]1}

matches any character in the specified range (a-d) preceding the character 1.

Design Hierarchy Conventions
Design hierarchy refers to the structure of your design. Design hierarchy 
conventions define a way to refer to objects within the design hierarchy.

The Identify tool set supports both VHDL and Verilog. These languages vary 
in their hierarchy conventions. The VHDL and Verilog languages contain 
design units and hierarchies of these design units. In VHDL these design 
units are entity/architecture pairs, in Verilog they are modules. VHDL and 
Verilog design units are organized hierarchically. Each of the following HDL 
design units creates a new level in the hierarchy:

Syntax Description

* Matches any sequence of characters

? Matches any single character

Syntax Description

[abcd] Matches any character in the specified set.

[a-d] Matches any character in a specified range.
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VHDL
• The top-level entity

• Architectures

• Component instantiation statements

• Process statements

• Control flow statements: if-then-else, and case

• Subprogram statements

• Block statements

Verilog
• The top-level module

• Module instantiation statements

• Always statements

• Control flow statements: if-then-else, and case

• Functions and tasks

Design Hierarchy References

A reference to an element in the design hierarchy consists of a path made up 
of references to design units (similar to a file reference described earlier). 
Regardless of the underlying HDL (VHDL or Verilog), the path separator 
character is always “/”:

/inst/reset_n

Absolute path names begin with a path separator character. The top-level 
design unit is represented by the initial “/”. Thus, a port on the top-level 
design unit is represented as:

/port_name

The architecture of the top-level VHDL design unit is represented as:

/arch
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Relative path names do not start with the path separator, and are relative to 
the current location in the design hierarchy. Initially, the current location is 
the top-level design unit, but commands exist that allow you to change the 
location. 

Note: Design unit references can be case sensitive depending on the HDL 
language. VHDL names are not case sensitive. In contrast, Verilog 
names are case sensitive. 

Wildcards

A wildcard is a command element you use to represent many different design 
hierarchy references. You can use wildcard design references as arguments 
to the design hierarchy commands. Conventions for wildcards are as follows:

Square brackets are used in hierarchy pattern matching as follows:

To use square brackets in pattern matching, you must delimit the entire 
name with curly braces { }. For example,

{[a-d]1}

matches any character in the specified range (a-d) preceding the character 1.

Syntax Description

* Matches any sequence of characters

? Matches any single character

Syntax Description

[abcd] Matches any character in the specified set.

[a-d] Matches any character in a specified range.
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C H A P T E R  2

System Overview

The Identify Actel Edition tool set is part of an HDL design flow process. The 
tool set is a dual-component system that allows you to probe your HDL 
design in the target environment. This system fits easily into your existing 
design flow with only a few modifications. 

The dual-component system consists of an Identify instrumentor software 
that allows you to select your design instrumentation at the HDL level and 
then create an on-chip hardware probe, and an Identify debugger software 
that interacts with the on-chip hardware probe and allows you to perform live 
debugging of your design. A combined system of instrumentor and debugger 
allows you to debug your design faster, easier, and more efficiently.

This chapter provides a high-level description of the Identify tool set, detailing 
how the instrumentor and debugger work and how they fit into your design 
flow. The chapter describes:

• The Debugging System

• The Design Flow

• System Components
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The Debugging System
The Identify tool set is based on the principle of in-system debugging. Using 
these tools allows you to debug your device in the target system, at target 
speed while debugging at the HDL level.

Starting with an HDL design, the Identify instrumentor enables you to create 
a debuggable HDL version of your design. Then, the Identify debugger 
communicates with this debuggable design, captures the operation of the 
design, and relates the captured data back to the original HDL design.

The Identify tool set captures the device operation by inserting an IICE (Intel-
ligent In-Circuit-Emulator) device into your design. The IICE is connected to 
signals of interest in your design and communicates with a host computer 
through a JTAG cable.

Your

IICE

Your System

Device
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The Design Flow
Design flows for HDL design and debugging vary according the type of 
hardware and device you use. Displayed below is the typical HDL design flow 
for a programmable hardware device and the design flow with the Identify tool 
set:

In the typical design flow, the first step is to create the HDL design files which 
are then synthesized to the target device. Following synthesis, the design is 
placed and routed, targeting a particular device. Then, the design is imple-
mented on the actual hardware by programming the device.

Program

Write HDL

Synthesis

Place
and

Route

Device

Program

Write HDL

Synthesis

Place
and

Route

Device

Instrument

Debug

Typical Design Flow Identify Design Flow
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The flow through the Identify tool set makes a very minor change to the 
typical flow. After the HDL is successfully created, the Identify instrumentor 
is used to create a debuggable HDL design. This design is then run through 
the rest of the typical process. After the device is programmed with the 
debuggable design, the Identify debugger is used to debug the design while it 
is running in the target system.

Because the Identify tool set provides logic debugging capabilities in the 
target system which is running at the target speed, the need for extensive 
system-level simulation can be reduced. Instead, the effort in the simulation 
step can concentrate on the much simpler and faster module-level simulation 
and some system-level simulation. Then the Identify debugger is used to help 
debug system-level functionality.
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System Components
The Identify system is made up of the following:

• IICE

• Identify Instrumentor

• Identify Debugger

IICE
The Intelligent In Circuit Emulator (IICE) is a custom block that is inserted 
into your design and connected to signals in the design by the Identify instru-
mentor in accordance with your interface specifications. The IICE samples 
internal signals and feeds the sampled signal information back to the Identify 
debugger where the data is transformed for interpretation at the HDL level.

The IICE block is actually made up of two different types of blocks. The first is 
the controller block and the second is the probe block. The probe block 
samples internal signal data and communicates with the controller block. 
The controller block communicates with the JTAG port.

IICE

TCK
TMS
TDI
TDO

 Identify Debugger

Large
Data
Path

Memory

Bus
Controller

Ext
I/OCPU

I/O

Filter
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The probe block contains the sample buffer where signal value data is stored. 
The probe block also contains the trigger logic that determines when the 
signal data is stored in the sample buffer.

The controller block receives the sample data from the probe block and sends 
it through the JTAG port to the Identify debugger.

Identify Instrumentor
The Identify instrumentor reads and analyzes the pre-synthesis HDL design 
and provides detailed information about the signals that can be observed and 
allows you to specify how to control signal observation.

The Identify instrumentor uses the HDL design files and the user-selection 
information to create the custom IICE block. The Identify instrumentor 
connects the IICE to the appropriate signals in the design and writes the new 
design to a user-specified location.

Identify Debugger
The Identify debugger lets you interact with the debuggable hardware at the 
HDL level. In the Identify debugger, you can activate breakpoints, set watch-
points, and view captured data related to the original source code or as 
waveforms. In the Identify debugger, you set trigger conditions that determine 
when to capture signal data. A trigger condition is a set of on-chip signal 
values or events. When a trigger condition occurs, data is transferred from 
the hardware device to the Identify debugger through the JTAG communica-
tion cable.
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C H A P T E R  3

Project Handling

A project contains all of the information required to instrument and debug a 
design. This information includes references to the HDL design files, the 
user-selected instrumentation, the settings used to create the IICE, the 
watchpoint and breakpoint activations from the debugger, and other system 
settings. Additionally, you can save the original design, in either an encrypted 
or non-encrypted format, in a project subdirectory. The project file is used to 
reproduce the exact state of the project in the Identify tool set.

This chapter describes the procedures for managing projects and includes:

• Projects in the Identify Instrumentor

• Identify Debugger Projects
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Projects in the Identify Instrumentor
This section describes how projects are defined between the Identify instru-
mentor and the synthesis tool.

• Integrated – the project is defined in the Synopsys FPGA synthesis tool 
and the synthesis tool is then used to launch the Identify instrumentor 
with the defined project

• Assisted – the project is defined in the Synopsys FPGA synthesis tool 
and the project file is then imported directly by the Identify instrumentor

Integrated Identify Instrumentor Projects
For Synplify Pro users, a Synopsys FPGA project (prj) file is passed to 
the Identify instrumentor to define the project. This project file speci-
fies the design files and their order, the device technology, and the 

design’s top-level module or entity.

To pass a Synplify Pro project to the Identify instrumentor, open the project 
in the synthesis tool’s Project view and:

1. Right click on the implementation and select New Identify Implementation 
from the popup menu.

2. Set/verify any technology, device mapping, or other pertinent options 
(see the implementation option descriptions in the Synopsys FPGA 
synthesis tool user guide) and click OK. A new, Identify implementation 
is added to the project view. 

Identify
Implementation
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Note: Because multiple implementations are not supported in the Synplify 
synthesis tool, the existing implementation is replaced with the Iden-
tify implementation.

3. Either right click on the Identify implementation and select Launch Identify 
Instrumentor from the popup menu or click the Launch Identify Instrumentor 
toolbar icon to launch the Identify instrumentor.

Note: If you are prompted to locate the executible, enter the path to the 
Identify software in the Locate Identify Installation field (use the browse 
button to the right of the field). Similarly, if you are prompted to 
select a license type, select the appropriate type from the list; check 
the Save as default license type box to avoid the license prompt in future 
sessions.

Launching the Identify instrumentor from the Synopsys FPGA synthesis tool: 

• Brings up the Identify instrumentor graphical interface.

• Opens the corresponding project (prj) file in the Identify instrumentor. 
The list of design files, their work directories, and the device family are 
extracted from the prj file.

• Automatically compiles the design files using the referenced synthesis 
tool compiler and displays the design hierarchy and the HDL file content 
with all the potential instrumentation marked and available for selec-
tion.

Assisted Identify Instrumentor Projects
An existing Synplify Pro project can be opened directly in the Identify instru-
mentor as an Identify project. To open the synthesis project, select File->Open 
project from the menu and select the synthesis tool project (prj) file. Opening a 
Synplify Pro project in the Identify instrumentor extracts the design files and 
their order, the specified device technology, and the design’s top-level module 
or entity. After the design files are extracted, the Identify instrumentor 
automatically compiles the files using the referenced synthesis tool compiler. 
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When compilation is complete, the instrumentation window displays the 
design hierarchy and the HDL file content with all the potential instrumenta-
tion marked and available for selection.

Viewing a Compiled File
Once a design has been successfully compiled, the contents of individual 
HDL files can be opened in the currently active IICE. To open an HDL file, 
either click on the filename or icon in the project view or right click on the 
filename or icon and select View hierarchy in Source Viewer from the popup menu. 
The selected file is displayed in the currently active IICE display.

Technology Cell Definitions

The Identify instrumentor normally instantiates module definitions for 
technology-specific cells. When a technology cell is not previously defined, the 
Identify instrumentor creates a dummy (empty) black box for the undefined 
module to allow the compilation to complete. 

To disable the generation of black boxes for uninstantiated module defini-
tions, enter the following command in the Identify instrumentor console 
window:

device technologydefinitions 0

Note: The command accepts all Boolean arguments (0, off, false, 1, on, or 
true). Entering the command without an argument returns the 
current setting.

Opening an Existing Identify Instrumentor Project
If a project already exists, you can open the project with the 
File->Open Project menu selection, the Open existing project icon, or the 
Open Project button in the project window. Each of these commands 
brings up the Open Project file dialog box to allow you to navigate to the 
directory containing the project (prj) file.
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A list of the four, most recent projects is maintained by the Identify instru-
mentor. Any of these projects can be opened directly from the File->Recent 
Projects menu. 

On opening a project, the data for that project is loaded into the Identify 
instrumentor. Loading a project retrieves all of the information stored in a 
project (user settings and file histories are automatically saved) and makes 
that project the current working project.

Instrumenting and Saving a Project
After setting up the IICE as described in Chapter 4, IICE Configuration and 
after selecting the instrumentation (selecting the signals for sampling and 
setting breakpoints) as described in Chapter 6, Identify Instrumentor, the 
project is instrumented and saved.

To instrument and save your project, select File->Save project instrumen-
tation from the menu or click on the Save project’s activated instrumentation 
icon.

Saving and instrumenting a project creates the following subdirectories and 
files in the Synopsys FPGA design directory:

• project file (projectName.prj) describing the project 

• instrumentation subdirectory (projectName_instr) that contains:
– instr_sources subdirectory containing the instrumented HDL files
– Tcl scripts for loading the instrumented design
– an optional orig_sources subdirectory containing the original HDL

Archiving a Project

When archiving an Identify project, be sure to include the projectName.prj file 
from the design directory and the following files and directories from the 
project directory:

• instr.db file

• syn.db file

• instr_sources directory

• orig_sources directory (if present)
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Identify Debugger Projects
This section includes descriptions of the following tasks associated with the 
Identify debugger:

• Opening an Identify Debugger Project

• Configuring an Identify Debugger Project

• Saving a Project

Opening an Identify Debugger Project
To open a project in the Identify debugger, the project must have 
been created in the Identify instrumentor (only the Identify instru-
mentor can create a project). To open an existing Identify debugger 
project from the Synopsys FPGA synthesis tool, highlight the Identify 

implementation and do one of the following: 

• select Launch Identify Debugger from the popup menu

• click the Launch Identify Debugger icon in the menu bar

• select Run->Launch Identify Debugger from the main menu

You can also open an existing project from the Identify debugger interface by 
selecting File->Open Project from the menu or by clicking on the Open existing 
project icon. The name of the project file will have a .bsp extension. A list of the 
four, most recent projects is maintained by the Identify debugger. Any of 
these projects can be opened directly from the File->Recent Projects menu. On 
opening, the data for the project is loaded into the Identify debugger. Loading 
a project retrieves all of the information stored in a project and makes that 
project the current working project.

Configuring an Identify Debugger Project
To configure an Identify debugger project, click the project tab to reopen the 
project window (reopening the project window shows the instrumentation 
and communication settings).
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Reviewing the Instrumentation Settings

The Instrumentation settings are displayed in the Instrumentation settings 
section of the project window. Because these configuration settings were 
specified in the Identify instrumentor and were used to construct the IICE, 
you cannot change these settings in the Identify debugger.

Changing the Communication Settings

The cable type and port specification communication settings can be set or 
changed from the project window. All Actel devices use the Actel_BuiltinJTAG 
cable type. Adjust the port setting based on the port where the communica-
tion cable is connected. Most often, lpt1 is the correct setting for parallel 
ports..
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Reviewing the JTAG Chain Settings

The JTAG chain settings is viewed by clicking the Show JTAG chain button in 
the communication settings section of the project window. Normally, the JTAG 
chain settings for the devices are automatically extracted from the design. 
When the chain settings cannot be determined, they must be created and/or 
edited using the chain command in the console window. The settings shown 
below are for a 2-device chain that has JTAG identification register lengths of 
8 and 10 bits. In addition, the device named “fpga” has been enabled for 
debugging.

Saving a Project
Saving a project in the Identify debugger saves the following additional 
project information to the project file:

• IICE Settings

• Instrumentations and activations.

To save a project in the Identify debugger, click the Save current activa-
tions icon or select File->Save activations from the menu.

“fpga” device enabled for debugging

Debug: Device ID: IR Length:
1.
2.

[ ]
[x]

prom
fpga

8
10
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C H A P T E R  4

IICE Configuration

An important part of the configuration of a project is setting the parameters 
for the Intelligent In-Circuit Emulator (IICE) in the Identify instrumentor. The 
IICE parameters determine the implementation of one or more IICE units for 
an individual instrumentation and configure the units so that proper 
communication can be established with the Identify debugger. The IICE 
parameters common to all IICE units are set in the Identify instrumentor 
project window and apply to all IICE units defined for the currently-active 
implementation; the IICE parameters unique to each IICE definition in a 
multi-IICE configuration are interactively set on one of two IICE Configuration 
dialog box tabs:

• IICE Sampler Tab – includes sample depth selection and clock specifica-
tion. 

• IICE Controller Tab – includes complex counter trigger width specification, 
selection of state machine triggering, and import/export of the IICE 
trigger signal.

This chapter describes how to configure one or more IICE units. 
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Multiple IICE Units
Multiple IICE units allow triggering and sampling of signals from different clock 
domains within a design. Each IICE unit is independent and can have unique 
IICE parameter settings including sample depth, sampling/triggering options, 
and sample clock and clock edge. During the debugging phase, individual or 
multiple IICE units can be armed.

Adding an IICE Unit
A New IICE button is included in the Identify instrumentor project window to 
allow an additional IICE to be defined for the current instrumentation. When 
you click the New IICE button, the project window is reduced to a tab and a 
new instrumentation window is opened with the HDL source code redis-
played without any instrumented signals.

Note: When you create a new IICE from the GUI, the name of the IICE unit 
is formed by adding a _n suffix to IICE (for example, IICE_0, IICE_1, 
etc.). If you create a new IICE from the command line using the Iden-
tify instrumentor iice new command, you can optionally include a 
name for the IICE.

Right-clicking on the IICE tab and selecting Configure IICE from the popup 
menu brings up the Configure IICE dialog box which allows you to define the 
parameters unique to the selected IICE (see Individual IICE Parameters, on 
page 33).

Note: Device family is selected in the synthesis tool; JTAG port selection, 
which is common to all IICE units for an instrumentation, is defined 
in the Identify instrumentor project window (see Common IICE Param-
eters, on page 31).
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Deleting an IICE Unit
To delete an IICE unit from your Identify instrumentor project, right-click on 
the tab of the IICE to be deleted and select Delete IICE from the popup menu.

Common IICE Parameters
The IICE parameters common to all IICE units defined for an instrumentation 
include:

• the IICE device family

• the JTAG port

These parameters are set/displayed in the project window for the currently-
active instrumentation. All IICE units in a multi-IICE configuration share 
these same parameter values. 

Device Family
The device family selected in the synthesis tool is reported in the Device family 
field (the field is read-only) and cannot be changed. 
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Note: If the device family specified in the tool is not supported, an 
error message is issued and you are prompted to exit the Iden-
tify instrumentor.

JTAG Port
The JTAG port parameter specifies the type of JTAG connection to be used to 
communicate with the on-chip IICE. The connection types are soft and builtin.

• builtin – indicates that the IICE is connected to the JTAG Tap controller 
available on the target device. 

• soft – indicates that the Synopsys Tap controller is to be used. The 
Synopsys FPGA Tap controller is more costly in terms of resources 
because it is implemented in user logic and requires four user I/O pins 
to connect to the communication cable.

See Chapter 9, Connecting to the Target System, for a description of which 
JTAG to use.
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Individual IICE Parameters
The individual parameters for each IICE are defined on the two tabs 
of the Configure IICE dialog box. To display this dialog box, first select 
the active IICE by clicking the appropriate IICE tab in the Identify 
instrumentor project window and then select Actions->Configure IICE 

from the menu or click on the Edit IICE settings icon. You can also right-click 
directly on the IICE tab and select Configure IICE from the popup menu.

IICE Sampler Tab
The IICE Sampler tab defines:

• IICE unit for multi-IICE configurations

• Sample depth

• Sampling/triggering options

• Sample clock and clock edge

IICE tabs
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Current IICE

The Current IICE field is used to identify the target IICE when there are multiple 
IICE units defined within an implementation. The IICE is selected from the 
drop-down menu.

Buffer Type

The Buffer type parameter specifies that behaviorial type RAM is to be used to 
capture the on-chip signal data and is the only available selection.

Sample Depth

The Sample depth parameter specifies the amount of data captured for each 
sampled signal. Sample depth is basically unlimited, but must be at least 8 
due to the pipelined architecture of the IICE. The sample depth is limited by 
the capacity of the chip(s) implementing the design.
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Sample depth can be maximized by taking into account the amount of RAM 
available on the chip. For instance if only a small amount of block RAM is 
used in the design, then a large amount of signal data can be captured into 
block RAM. If most of the block RAM is used for the design, then only a small 
amount is available to be used for signal data. In this case, it may be more 
advantageous to use logic RAM.

Allow Qualified Sampling

The Allow qualified sampling check box, when checked, causes the Identify 
instrumentor to build an IICE block that is capable or performing qualified 
sampling. When qualified sampling is enabled, one data value is sampled 
each time the trigger condition is true. With qualified sampling, you can 
follow the operation of the design over a longer period of time (for example, 
you can observe the addresses in a number of bus cycles by sampling only 
one value for each bus cycle instead of a full trace). Using qualified sampling 
includes a slight area and clock-speed penalty.

Allow Always-Armed Triggering

The Allow always-armed triggering check box, when checked, saves the sample 
buffer for the most recent trigger and waits for the next trigger or until inter-
rupted. When always-armed sampling is enabled, a snapshot is taken each 
time the trigger condition becomes true. With always-armed triggering, you 
always acquire the data associated with the last trigger condition prior to the 
interrupt. This mode is helpful when analyzing a design that uses a repeated 
pattern as a trigger (for example, bus cycles) and then randomly freezes. You 
can retrieve the data corresponding to the last time the repeated pattern 
occurred prior to freezing. Using always-armed sampling includes a slight 
area and clock-speed penalty.
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Sample Clock

The Sample clock parameter determines when signal data is captured by the 
IICE. The sample clock can be any signal in the design that is a single-bit 
scalar type. Enter the complete hierarchical path of the signal as the param-
eter value. 

Care must be taken when selecting a sample clock because signals are 
sampled on an edge of the clock. For the sample values to be valid, the 
signals being sampled must be stable when the specified edge of the sample 
clock occurs. Usually, the sample clock is either the same clock that the 
sampled signals are synchronous with or a multiple of that clock. The sample 
clock must use a scalar, global clock resource of the chip and should be the 
highest clock frequency available in the design. The source of the clock must 
be the output from a BUFG/IBUFG device.

You can also select the sample clock from the instrumentation window by 
right-clicking on the watchpoint icon in the source code display and selecting 
Sample Clock from the popup menu. The icon for the selected (single-bit) signal 
changes to a clock face as shown in the following figure.

Note: You must set the other individual IICE parameters from the Configure 
IICE dialog box including the sample clock edge.

BUFG
DCM/PLL

Sample Clock
Icon
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Clock Edge

The Clock edge radio buttons determine if samples are taken on the rising 
(positive) or falling (negative) edge of the sample clock. The default is the 
positive edge. 

IICE Controller Tab
The IICE Controller tab selects the IICE controller’s triggering mode. All of these 
instrumentation choices have a corresponding effect on the area cost of the 
Identify IICE.

Current IICE

The Current IICE field is used to identify the target IICE when there are multiple 
IICE units defined within an implementation. The IICE is selected from the 
drop-down menu.
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Simple Triggering

Simple triggering allows you to combine breakpoints and watchpoints to 
create a trigger condition for capturing the sample data.

Complex-Counter Triggering

Complex-counter triggering augments the simple triggering by instrumenting 
a variable-width counter that can be used to create a more complex trigger 
function. Use the width setting to control the desired width of the counter. 

State-Machine Triggering

State-machine triggering allows you to pre-instrument a variable-sized state 
machine that can be used to specify an ultimately flexible trigger condition. 
Use Trigger states to customize how many states are available in the state 
machine. Use Trigger condition to control how many independent trigger condi-
tions can be defined in the state machine. For more information on state-
machine triggering, see State Machine Triggering, on page 116.

Import External Trigger Signals

External triggering allows the trigger from an external source to be imported 
and configured as a trigger condition for the active IICE. The external source 
can be a second IICE located on a different device or external logic on the 
board rather than the result of an Identify instrumentation. The imported 
trigger signal includes the same triggering capabilities as the internal trigger 
sources used with state machines. The adjacent field selects the number of 
external trigger sources with 0, the default, disabling recognition of any 
external trigger. Selecting one or more external triggers automatically enables 
state-machine triggering.

Note: When using external triggers, the pin assignments for the corre-
sponding input ports must be defined in the synthesis or place and 
route tool.
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Export IICE Trigger Signal

The Export IICE trigger signal check box, when checked, causes the master 
trigger signal of the IICE hardware to be exported to the top-level of the 
instrumented design.

Allow cross-triggering in IICE

The Allow cross-triggering in IICE check box, when checked, allows this IICE unit 
to accept a cross-trigger from another IICE unit. For more information on 
cross-triggering, see State-Machine Editor, on page 126.
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C H A P T E R  5

Support for Instrumenting HDL

The Identify Actel Edition tool set fully supports the synthesizable subset of 
both Verilog and VHDL design languages. Designs that contain a mixture of 
VHDL and Verilog can be debugged – the Identify software reads in your 
design files in either language.

There are some limitations on which parts of a design can be instrumented 
by the Identify instrumentor. However, in all cases you can always compile 
your design and instrument all other parts of your design.

The instrumentation limitations are usually related to language features. 
These limitations are described in this chapter.

• VHDL Instrumentation Limitations

• Verilog Instrumentation Limitations

• SystemVerilog Instrumentation Limitations, on page 47
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VHDL Instrumentation Limitations
The synthesizable subsets of VHDL IIEEE 1076-1993 and IEEE 1076-1987 
are supported in the current release of the Identify debugger.

Design Hierarchy

Entities that are instantiated more than once are supported for instrumenta-
tion with the exception that signals that have type characteristics specified by 
unique generic parameters cannot be instrumented.

Subprograms

Subprograms such as VHDL procedures and functions cannot be instru-
mented. Signals and breakpoints within these specific subprograms cannot 
be selected for instrumentation.

Loops

Breakpoints within loops cannot be instrumented.

Generics

VHDL generic parameters are fully supported as long as the generic param-
eter values for the entire design are identical during both instrumentation 
and synthesis.

Transient Variables

Transient variables defined locally in VHDL processes cannot be instru-
mented. 
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Breakpoints and Flip-flop Inferencing

Breakpoints inside flip-flop inferring processes can only be instrumented if 
they follow the coding styles outlined below:

For flip-flops with asynchronous reset:

process(clk, reset, ...) begin
if reset = '0' then

reset_statements;
elsif clk’event and clk = '1' then

synchronous_assignments;
end if;

end process;

For flip-flops with synchronous reset or without reset:

process(clk, ...) begin
if clk’event and clk = '1' then

synchronous_assignments;
end if;

end process;

Or:

process begin
wait until clk’event and clk = '1'

synchronous_assignments;
end process;

The reset polarity and clock edge specifications above are only exemplary. 
The Identify software has no restrictions with respect to the polarity of reset 
and clock. A coding style that uses wait statements must have only one wait 
statement and it must be at the top of the process.

Using any other coding style for flip-flop inferring processes will have the 
effect that no breakpoints can be instrumented inside the corresponding 
process. During design compilation, the Identify instrumentor issues a 
warning that the code cannot be instrumented.
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Verilog Instrumentation Limitations
The synthesizable subset of Verilog HDL IEEE 1364-1995 and 1364-2001 are 
supported.

Subprograms

Subprograms such as Verilog functions and tasks cannot be instrumented. 
Signals and breakpoints within these specific subprograms cannot be 
selected for instrumentation.

Loops

Breakpoints within loops cannot be instrumented.

Parameters

Verilog HDL parameters are fully supported. However, the values of all the 
parameters throughout the entire design must be identical during instru-
mentation and synthesis.

Locally Declared Registers

Registers declared locally inside a named begin block cannot be instrumented 
and will not be offered for instrumentation. Only registers declared in the 
module scope and wires can be instrumented.

Verilog Include Files

There are no limitations on the instrumentation of 'include files that are refer-
enced only once. When an 'include file is referenced multiple times as shown in 
the following example, the following limitations apply:

• If the keyword module or endmodule, or if the closing ‘)’ of the module port 
list is located inside a multiply-included file, no constructs inside the 
corresponding module or its submodules can be instrumented.

• If significant portions of the body of an always block are located inside a 
multiply-included file, no breakpoints inside the corresponding always 
block can be instrumented.
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If either situation is detected during design compilation, the Identify Instru-
mentor issues an appropriate warning message.

As an example, consider the following three files:

adder.v File
module adder (cout, sum, a, b, cin);
parameter size = 1; 
output cout;
output [size-1:0] sum; 
input cin;
input [size-1:0] a, b; 
assign {cout, sum} = a + b + cin;
endmodule

adder8.v File 
`include "adder.v"
module adder8 (cout, sum, a, b, cin);
output cout;
parameter my_size = 8; 
output [my_size - 1: 0] sum;
input [my_size - 1: 0] a, b;
input cin;
adder #(my_size) my_adder (cout, sum, a, b, cin);
endmodule

adder16.v File 
`include "adder.v"
module adder16 (cout, sum, a, b, cin);
output cout;
parameter my_size = 16; 
output [my_size - 1: 0] sum;
input [my_size - 1: 0] a, b;
input cin;
adder #(my_size) my_adder (cout, sum, a, b, cin);
endmodule

There is a workaround for this problem. Make a copy of the include file and 
change one particular include statement to refer to the copy. Signals and 
breakpoints that originate from the copied include file are now instrument-
able.



LO

Chapter 5: Support for Instrumenting HDL Verilog Instrumentation Limitations

Copyright © 2011 Synopsys, Inc. Identify Actel Edition User Guide
46 March 2011

Macro Definitions

The code inside macro definitions cannot be instrumented. If a macro defini-
tion contains important parts of some instrumentable code, that code also 
cannot be instrumented. For example, if a macro definition includes the case 
keyword and the controlling expression of a case statement, the case state-
ment cannot be instrumented.

Always Blocks

Breakpoints inside a synchronous flip-flop inferring an always block can only 
be instrumented if the always block follows the coding styles outlined below:

For flip-flops with asynchronous reset:

always @(posedge clk or negedge reset) begin
if(!reset) begin

reset_statements;
end

else begin
synchronous_assignments;

end;
end;

For flip-flops with synchronous reset or without reset:

always @(posedge clk) begin
synchronous_assignments;

end process;

The reset polarity and clock edge specifications and the usage of begin blocks 
above are only exemplary. The Identify instrumentor has no restrictions with 
respect to these other than required by the language.

For other coding styles, the Identify instrumentor issues a warning that the 
code is not instrumentable.
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SystemVerilog Instrumentation Limitations
The synthesizable subsets of Verilog HDL IEEE 1364-2005 (SystemVerilog) 
are supported with the following exceptions.

Typedefs

You can create your own names for type definitions that you use frequently in 
your code. SystemVerilog adds the ability to define new net and variable user-
defined names for existing types using the typedef keyword. Only typedefs of 
supported types are supported.

Struct Construct

A structure data type represents collections of data types. These data types 
can be either standard data types (such as int, logic, or bit) or, they can be 
user-defined types (using SystemVerilog typedef). Signals of type structure can 
only be sampled and cannot be used for triggering; individual elements of a 
structure cannot be instrumented, and it is only possible to instrument 
(sample only) an entire structure. The following code segment illustrates 
these limitations:

In the above code segment, port signal sig_oport_P_Struc_data is a packed 
structure consisting of two elements (up_nibble and lo_nibble) which are of a 
user-defined datatype. As elements of a structure, these elements cannot be 
instrumented. The signal sig_oport_P_Struc_data can be instrumented for 
sampling, but cannot be used for triggering (setting a watch point on the 
signal is not allowed). If this signal is instrumented for sample and trigger, 
the Identify instrumentor allows only sampling and ignores triggering. 

module lddt_P_Struc_top (
   input  sig_clk, sig_rst,
   .
   .
   .
   output struct packed {
      logic_nibble up_nibble;
      logic_nibble lo_nibble;
   } sig_oport_P_Struc_data
);

Cannot be instrumented
(no sampling and 

no triggering)

Instrumentable only for
sampling; no triggering
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Union Construct

A union is a collection of different data types similar to a structure with the 
exception that members of the union share the same memory location. 
Unions are not supported for instrumentation and it is not possible to select 
a union datatype signal for either sampling or triggering. The following code 
segment illustrates this limitation:

In the above code, port signals sig_iport_P_Union_data and sig_oport_P_Union_data 
are of type union. Code that includes union constructs compiles successfully 
without error in the synthesis tool, but is disabled for instrumentation in the 
Identify instrumentor. 

Arrays

Arrays having more than one dimension cannot be instrumented for 
triggering. The following code segment illustrates these limitation:

In the above code segment, waddress, waddress1, and raddress are one dimen-
sional packed arrays. These signals can be instrumented for both sampling 
and triggering. Signals data and data1 are 2-dimensional arrays. These signals 
can only be instrumented for sampling, and triggering is not allowed. 

module lddt_P_Union_top (
   input sig_clk, sig_rst,
   input union packed {
      type_P_Struc_datapkt P_Struc_data;
      logic [7:0][7:0] P_Array_data;
      } sig_iport_P_Union_data,
   output union packed {
      type_P_Struc_datapkt P_Struc_data;
      logic [7:0][7:0] P_Array_data;
      } sig_oport_P_Union_data
);

Cannot be instrumented
(no sampling and 

no triggering)

module test (clock,waddress,waddress1,
   raddress,we,data,data1,q,q1);
input clock;
input [8:0] waddress,waddress1,raddress;
input we;
input [255:0] [31:0] data, data1;
output reg [31:0] q, q1; Instrumented for sampling only
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Partial instrumentation of multi-dimensional and multi-dimensional arrays 
of struct is not permitted, and instrumentation of mult-dimensional arrays of 
packed unions is not supported.

Interface

Interface and interface items are not supported for instrumentation and 
cannot be used for sampling or triggering. The following code segment illus-
trates this limitation:

interface ff_if (input logic clk, input logic rst, 
   input logic din, output logic dout);
modport write (input clk, input rst, input din, output dout);
endinterface: ff_if

module top (input logic clk, input logic rst, 
   input logic din, output logic dout) ;

   ff_if ff_if_top(.clk(clk), .rst(rst), .*);
   sff UUT (.ff_if_0(ff_if_top.write));
endmodule

In the above code segment, the interface instantiation of interface ff_if is 
ff_if_top which cannot be instrumented. Similarly, interface item modport write 
cannot be instrumented.

Port Connections for Interfaces and Variables

Instrumentation of named port connections on instantiations to implicitly 
instantiate ports is not supported.

Packages

Packages permit the sharing of language-defined data types, typedef user-
defined types, parameters, constants, function definitions, and task defini-
tions among one or more compilation units, modules, or interfaces. Instru-
mentation within a package is not supported.

Concatenation Syntax

The concatenation syntax on an array watchpoint signal is not accepted by 
the Identify debugger. To illustrate, consider a signal declared as: 

bit [3:0] sig_bit_type;
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To set a watchpoint on this signal, the accepted syntax in the Identify 
debugger is:

watch enable –iice IICE {/sig_bit_type} {4’b1001}

The 4-bit vector cannot be divided into smaller vectors and concatenated (as 
accepted in SystemVerilog). For example, the below syntax is not accepted:

watch enable –iice IICE {/sig_bit_type} {{2’b10,2’b01}}
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C H A P T E R  6

Identify Instrumentor

The Identify instrumentor performs the following functions:

• defines the instrumentation for the user’s HDL design

• creates the instrumented HDL design

• creates the associated IICE

• creates the design database

The remainder of this chapter describes:

• In this section, each of these areas and their uses is described. The 
following discussions assume that a project (with an HDL design) has 
been created and loaded into the Identify instrumentor.

• Commands and Procedures

Identify Instrumentor Windows
The Graphical User Interface (GUI) for the Identify instrumentor is divided 
into the following three major areas:

• Instrumentation Window

• Project Window

• Console Window
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In this section, each of these areas and their uses is described. The following 
discussions assume that a project (with an HDL design) has been created and 
loaded into the Identify instrumentor.

Instrumentation Window
The instrumentation window includes a hierarchy browser on the left and the 
source-code display on the right. The window is displayed when you open a 
synthesis project (prj) file in the Identify instrumentor by either lauching the 
Identify instrumentor from a syntheis project or explicitly loading a synthesis 
project into the Identify instrumentor.

Hierarchy Browser

The hierarchy browser on the left shows a graphical representation of the 
design’s hierarchy. At the top of the browser is the ROOT node. The ROOT 
node represents the top-level entity or module of your design. For VHDL 
designs, the first level below the ROOT is the architecture of the top-level 
entity. The level below the top-level architecture for VHDL designs, or below 
the ROOT for Verilog designs, shows the entities or modules instantiated at 
the top level.

Hierarchy Browser Source-Code Display
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Clicking on a + sign opens the entity/module instance so that the hierarchy 
below that instance can be viewed. Lower levels of the browser represent 
instantiations, case statements, if statements, functional operators, and 
other statements.

Single clicking on any element in the hierarchy browser causes the associ-
ated HDL code to be visible in the adjacent source code display.

A popup menu is available in the hierarchy browser to set or clear break-
points or watchpoints at any level of the hierarchy. Positioning the cursor 
over an element and clicking the right mouse button displays the following 
menu.

The selected operation is applied to all breakpoints or signal watchpoints at 
the selected level of hierarchy.

Note: You cannot instrument signals when a sample clock is included in 
the defined group. 
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The popup menu functions can be duplicated in the console window using 
the Identify instrumentor hierarchy command in combination with either the 
Identify instrumentor breakpoints or signals command. A typical Identify instru-
mentor command sequence to instrument the signal set within a design 
would be:

signals add [hierarchy find -type signal /] 

In the above sequence, the slash (/) indicates that all of the signals in the root 
hierarchy (entire design) are to be instrumented. If you specify a lower level of 
hierarchy following the slash, the command only applies to that hierarchical 
level. For more information on the Identify instrumentor breakpoints, signals, 
and hierarchy commands, see the Reference Manual.

Black-box modules are represented by a black icon, and their contents can 
not be instrumented. Also, certain modules cannot be instrumented (see 
Chapter 5, Support for Instrumenting HDL, for a specific description). Modules 
that cannot be instrumented are displayed in a disabled state in a grey font.

Source Code Display

The HDL source code in the source code display is annotated with signals 
that can be probed and breakpoints that can be selected. Signals that can be 
selected for probing by the IICE are underlined, colored in blue, and have 
small watchpoint icons next to them. Source lines that can be selected as 
breakpoints have small circular icons in the left margin adjacent to the line 
number.
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Project Window
The project window is displayed when you first start up the Identify instru-
mentor (to invoke the Identify instrumentor, see Projects in the Identify Instru-
mentor, on page 22). This window includes a set of project management 
buttons and, after a project is compiled, a symbolic view of the project on the 
left and an area for setting the common IICE parameters on the right (the 
area below the common IICE parameters shows the top-level unit when the 
design was compiled).

The project window can be redisplayed at any time by clicking the project 
name tab that remains visible when an instrumentation window is displayed.

Common IICE

Project
Buttons

Project
Symbols

Parameters

Top-Level
Unit
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Console Window
The console window appears below the project or instrumentation window 
and displays a history of Identify instrumentor commands that have been 
executed, including those executed by menu selections and button clicks. 
The Identify instrumentor console window also allows you to enter 
commands and to view the results of all Identify instrumentor commands. 
Command history recording is available through a transcript command (see the 
Reference Manual).
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Commands and Procedures
The following sections describe basic Identify instrumentor commands and 
procedures. 

Opening Projects
To open an existing synthesis project in the Identify instrumentor, do any of 
the following:

• Click the Open Project button in the Project window

• Click the Open existing project icon 

• Select File->Open Project form the menu

Any of the above methods bring up the Open Project file dialog box where you 
can select the project (prj file) to open. You can also open the project in the 
synthesis tool and then launch the Identify instrumentor from the Identify 
implementation. See Chapter 3, Project Handling, for details on setting up 
and managing projects.

Set Working Directory
The working directory is used as the starting location for reading and writing 
files. Setting the working directory to the location of your project files makes 
working with the Identify instrumentor easier.

To set the working directory, select the File->Working directory menu selection 
and navigate to your project location.

Note: When importing a Synopsys FPGA synthesis project into the Identify 
instrumentor, the working directory is automatically set from the 
corresponding project file.
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Execute Script Files
A script file is a file that contains Identify instrumentor Tcl commands. A 
script file is a convenient way to capture a command sequence you would like 
to repeat. To execute a script file, select the File->Execute Script menu selection 
in the Identify instrumentor user interface and navigate to the location of 
your script file or use the source command (see Chapter 4, Alphabetical 
Command Reference, in the Reference Manual).

Select Signals for Data Sampling
To select a signal to be sampled, simply click on the “watch” icon 
next to the signal name in the Identify instrumentor instrumentation 
window; a popup menu appears that allows the signal to be selected 
for sampling, triggering, or both.

To control the overhead for the trigger logic, always instrument signals that 
are not needed for triggering with the Sample only selection (the watchpoint 
icon is blue for sample-only signals). 

Qualified clock signals can be specified as the Sample Clock (see Sample 
Clock, on page 36) and bus segments can be individually specified (see Instru-
menting Buses, on page 61).

Scalar Signal Popup Bus Signal Popup
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If the icon is clear (unfilled), the signal is disabled for sampling (not instru-
mented), and if the icon is red, the signal is enabled for triggering only. If the 
icon is blue, the signal is enabled for sampling only, and if the icon is green, 
the signal is enabled for both sampling and triggering. In the example below, 
notice that when signal “grant1” is enabled, the console window displays the 
text command that implements the selection and the results of executing the 
command. 

Signals that can be selected
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To disable a signal for sampling or triggering, select the signal in the Identify 
instrumentor instrumentation window and then select Not instrumented from 
the popup menu; the watchpoint icon will again be clear (unfilled).

Note: You can use Find to recursively search for signals and then instru-
ment selected signals directly from the Find dialog box (see Search for 
Design Objects, on page 73).

Signal “grant1” selected
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Instrumenting Buses
Entire buses or individual or groups of bits of a bus can be independently 
instrumented. 

Instrumenting a Partial Bus

To instrument a sequence (range) of bits of a bus:

1. Place the cursor over a bus that has not been fully instrumented and 
select Add partial instrumentation to display the following dialog box.

2. In the dialog box, enter the most- and least-significant bits in the MSB 
and LSB fields. Note that the bit range specified is contiguous; to 
instrument non-contiguous bit ranges, see the section, Instrumenting 
Non-Contiguous Bits or Bit Ranges, on page 62.

Note: When specifying the MSB and LSB values, the index order of the bus 
must be followed. For example, when defining a partial bus range for 
bus [63:0] (or “63 downto 0”), the MSB value must be greater than the 
LSB value. Similarly, for bus [0:63] (or “0 upto 63”), the MSB value 
must be less that the LSB value.

3. Select the type of instrumentation for the specified bit range from the 
drop-down menu and click OK.

When you click OK, a large letter “P” is displayed to the left of the bus 
name in place of the watchpoint icon. The color of this letter indicates if 
the partial bus is enabled for triggering only (red), for sampling only 
(blue), or for both sampling and triggering (green).
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Instrumenting Single Bits of a Bus

To instrument a single bit of a bus, enter the bit value in the MSB field of the 
Add partial bus dialog box, leave the LSB field blank, and select the instrumen-
tation type from the drop-down menu as previously described.

Instrumenting Non-Contiguous Bits or Bit Ranges

To instrument non-contiguous bits or bit ranges:

1. Instrument the first bit range or bit as described in one of the two 
previous sections. 

2. Re-position the cursor over the bus, click the right mouse button, and 
again select Add partial instrumentation to redisplay the Add partial bus dialog 
box. Note that the previously instrumented bit or bit range is now 
displayed.

3. Specify the bit or bit range to be instrumented as previously described, 
select the type of instrumentation from the drop-down menu, and click 
OK. If the type of instrumentation is different from the existing 
instrumentation, the letter “P” will be yellow to indicate a mixture of 
instrumentation types.

Note: Bits cannot overlap groups (a bit cannot be instrumented more than 
once).
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Changing the Instrumentation Type

To change the instrumentation type of a partial bus:

1. Position the cursor over the bus and click the right mouse button.

2. Highlight the bit range or bit to be changed and select the new 
instrumentation type from the adjacent menu.

Note: The above procedure is also used to remove the instrumentation from 
a bit or bit range by selecting Not instrumented from the menu.

Partial Instrumentation
Partial instrumentation allows fields within a record or a structure to be 
individually instrumented. Selecting a compatible signal for instrumentation, 
either in the RTL window or through the Find dialog box, enables the partial 
instrumentation feature and displays a dialog box where the field name and 
its type of instrumentation can be entered. 

When instrumented, the signal is displayed with a P icon in place of the 
watchpoint (glasses) icon to indicate that portions of the record are instru-
mented. The P icon is the same icon that is used to show partial instrumenta-
tion of a bus and uses a similar color coding:

• Green indicates that all fields of the record are instrumented for sample 
and trigger

• Blue indicates that all fields of the record are instrumented for sample 
only
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• Pink indicates that all fields of the record are instrumented for trigger 
only

• Yellow indicates that not all fields of the record are instrumented the 
same way.

The figure below shows the partial instrumentation icon on signal tt. The 
yellow color indicates that the individual fields (tt.r2 and tt.c2) are assigned 
different types of instrumentation.

The Find dialog also uses the partial instrumentation icon to show the state of 
instrumentation on fields of partially instrumented records.

Note: Partial instrumentation can only be added to a field or record one 
slice-level down in the signal hierarchy.
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Sampling Signals in a Folded Hierarchy
When a design contains entities or modules that are instantiated more than 
once, it is termed to have a folded hierarchy (folded hierarchies also occur 
when multiple instances are created within a generate loop). By definition, 
there will be more than one instance of every signal in a folded entity or 
module. To allow you to instrument a particular instance of a folded signal, 
the Identify instrumentor automatically recognizes folded hierarchies and 
presents a choice of all possible instances of each signal with the hierarchy. 

The choices are displayed in terms of an absolute signal path name 
originating at the top-level entity or module. The list of choices for a 
particular signal is accessed by clicking the “watch” icon or corre-
sponding signal.

The example below consists of a top-level entity called two-level and two 
instances of the repeated_unit entity. The source code of repeated_unit is 
displayed, and the list of instances of the val signal is displayed by clicking on 
the watchpoint icon or the signal name. Two instances of the signal val are 
available for sampling: 

/rtl/cnt_inst0/val
/rtl/cnt_inst1/val

Either, or both, of these instances can be selected for sampling by selecting 
the signal instance and then sliding the cursor over to select the type of 
sampling to be instrumented for that signal instance.

The list of instrumentable instances of signal val
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The color of the watchpoint icon is determined as follows:

• If no instances of the signal are selected, the watchpoint icon is clear.

• If some, but not all, instances of the signal are defined for sampling, the 
watchpoint icon is yellow.

• If all instances are defined for sampling, the color of the watchpoint icon 
is determined by the type of sampling specified (all instances sample 
only: blue, all instances trigger only: red, all instances sample and 
trigger: green, all instances in any combination: yellow).

Alternately, any of the instances of a folded signal can be selected or 
deselected at the Identify instrumentor console window prompt by using the 
absolute path name of the instance. For example, 

signals add /rtl/cnt_inst1/val

See the Reference Manual for more information.

To disable an instance of a signal that is currently defined for sampling, click 
on the watchpoint icon or signal, select the instance from the list displayed, 
and select Not instrumented.

For related information on folded hierarchies in the Identify debugger, see 
Activating/Deactivating Folded Instrumentation, on page 88 and Displaying 
Data from Folded Signals, on page 96.

Select Breakpoints
Breakpoints are used to trigger data sampling. Only the breakpoints 
that are instrumented in the Identify instrumentor can be enabled as 
triggers in the Identify debugger. To instrument a breakpoint in the 

Identify instrumentor, simply click on the circular icon to the left of the line 
number. The color of the icon changes to green when enabled.
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Once a breakpoint is instrumented, the Identify instrumentor creates trigger 
logic that becomes active when the code region in which the breakpoint 
resides is active.

In this example, the code region of the instrumented breakpoint is active if 
the variable current_state is state zero (s_ZERO) and the signal clr is not ‘0’ when 
the clock event occurs.

Select Breakpoints Residing in Folded Hierarchy
If a design contains entities or modules that are instantiated more than once, 
the design is termed to have folded hierarchy. By definition, there will be 
more than one instance of every breakpoint in a folded entity or module. To 
allow you to instrument a particular instance of a folded breakpoint, the 
Identify instrumentor automatically detects folded hierarchy and presents a 
choice of all possible instances of each breakpoint.

The choices are displayed in terms of an absolute breakpoint path name 
originating at the top-level entity or module. The list of choices for a partic-
ular breakpoint is accessed by clicking on the breakpoint button to the left of 
the line number.

Breakpoint on line 23 enabled
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The example below consists of a top-level entity called top and two instances 
of the repeated_unit entity. The source code of repeated_unit is displayed; the list 
of instances of the breakpoint on line 100 is displayed by clicking on the 
breakpoint icon next to the line number. As shown in the following figure, 
three instances of the breakpoint are available for sampling. 

Any or all of these breakpoints can be selected by clicking on the corre-
sponding line entry in the list displayed.

The color of the breakpoint icon is determined as follows:

• If no instances of the breakpoint are selected, the icon is clear in color.

• If some, but not all, instances of the breakpoint are selected, the icon is 
yellow. 

• If all instances are selected, the icon is green.

Alternately, any of the instances of a folded breakpoint can be selected or 
deselected at the Identify instrumentor console window prompt by using the 
absolute path name of the instance. For example, 

breakpoints add 
/rtl/inst0/rtl/process_18/if_20/if_23/repeated_unit.vhd:24

See the Reference Manual for more information.

The lines in the list of breakpoint instances act to toggle the selection of an 
instance of the breakpoint. To disable an instance of a breakpoint that has 
been previously selected, simply select the appropriate line in the list box.

Folded breakpoint on line 100 selected
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Configure the IICE
If the IICE configuration parameters for the active IICE need to be 
changed, use the Actions->Configure IICE menu selection or the Edit IICE 
settings icon to change them. Chapter 4, IICE Configuration, discusses 
how to set these parameters for both single- and multi-IICE configu-
rations.

Write Instrumented Design
To create the instrumented design, you must first complete the following 
steps:

1. A synthesis project with all source files must be defined

2. Specify IICE parameters

3. Select signals to sample

4. Select breakpoints to instrument

5. Optionally include the original HDL source 

Note: To include the original HDL source with the project, select 
Options->Instrumentation preferences from the menu to display the Instru-
mentation Preferences dialog box and select the Save original source in 
instrumentation directory check box. If the original source is to be 
encrypted, additionally select the Use encryption check box. Selecting 
Save original source in instrumentation directory saves the original HDL 
source to the orig_sources subdirectory in the instrumentation direc-
tory when you instrument your design. 

Finally, click on the Save project’s active instrumentation icon to write out 
the instrumented design and the design project, and to update the 
design database. If you are including an encrypted HDL source (Use 
encryption box checked), you are first prompted to supply a password 
for the encryption.
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Including Original HDL Source

Including the original HDL source with the instrumented project simplifies 
design transfer when instrumentation and debugging are performed on 
separate machines and is especially useful when a design is being debugged 
on a system that does not have access to the original sources. 

As explained in Debugging on a Different Machine, on page 104, you can 
simply copy the entire instrumentation directory to the debug system; the 
Identify project will be able to locate the original sources for display. To 
include the original HDL source, select the Save original source in instrumentation 
directory check box from the Instrumentor Preferences dialog box (Options->Instru-
mentation preferences) before you save and instrument your project. The clear 
text or encrypted source is included in the orig_sources subdirectory.

When the Use encryption check box is additionally selected, the original sources 
are encrypted when they are written into the orig_sources subdirectory. The 
encryption is based on a password that is requested when you write out the 
instrumented project. Encryption allows you to debug on a machine that you 
feel would be too unsecure to store your sources. After you transfer the 
instrumentation directory to the unsecure machine, you are prompted to 
reenter the encryption password when you open the project in the debugger. 

For maximum security when selecting an encryption password:

• use spaces to create phrases of four or more words (multiple words 
defeat dictionary-type matching)

• include numbers, punctuation marks, and spaces 

• make passwords greater than 16 characters in length

Note: Passwords are the user’s responsibility; Synopsys cannot recover a 
lost or forgotten password.

The decrypted files are never written to the unsecure machine’s hard disk. 
Users are discouraged from transferring the instr_sources directory to the 
unsecure machine, as this directory is not required for debugging.
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Synthesizing Instrumented Designs
When you instrument a design, the following files and subdirectories are 
written or created in the instrumentation implementation directory (rev_n):

• instr_sources subdirectory containing:
– the instrumented HDL files – these source files contain the entire 

instrumented design
– the IICE core file (syn_dics.v or syn_dics.vhd) 
– a Synopsys FPGA constraint file (syn_dics.sdc) – this file can be used 

directly by the Synopsys FPGA synthesis tool

• an optional orig_sources subdirectory containing the original HDL files in 
either encrypted or clear-text format

• synplify.tcl – an automatically generated script file for loading the instru-
mented design into the synthesis tool. The script references the IICE 
core syn_dics.v or syn_dics.vhd file and the syn_dics.sdc constraints file. 

Note: When instrumenting a VHDL file that is not compiled into the work 
library, make sure that the syn_dics.vhd file is included in the 
synthesis project ahead of the user design files. Additionally, this file 
must be compiled into the work library.
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List Instrumented Signals
To view all of the signals currently instrumented in the entire design, 
use the Actions->Show Instrumented Signals menu selection or click the 
Show Instrumented Signals icon. The result of listing the signals is 
displayed in the Find dialog box.

Signals selected for samplingFind dialog
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List All Signals
To view all of the signals in the design, use the Actions->Show All Signals menu 
selection.

List Signals Available for Instrumentation
To see only the signals in the design available for instrumentation, 
use the Actions->Show Possible Signals menu selection or the Show 
Possible Signals icon.

List Instrumented Breakpoints
To list all of the breakpoints that have been instrumented, use the 
Actions->Show Instrumented Breakpoints menu selection or the Show Instru-
mented Breakpoints icon.

List All Breakpoints
To list all breakpoints, use the Actions->Show All Breakpoints menu selection.

List Breakpoints Available for Instrumentation
To list all of the breakpoints that are available for instrumentation, 
use the Actions->Show Possible Breakpoints menu selection or the Show 
Possible Breakpoints icon.

Search for Design Objects
The Find dialog box is a general utility to recursively search for 
signals, breakpoints, and/or instances. To invoke the Find dialog box, 
use the Edit->Find menu selection or the Display find dialog icon.
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The Find dialog box has an area for specifying the objects to find, and an area 
for displaying the results of the search.

The search specification has these options:

• Of type: – specify which type of object to search for: breakpoint, signal, 
instance, or “*” (any). The default is “*” (any).

• Named: – specify a name, or partial name to search for in the design. Wild 
cards are allowed in the name. The default is “*” (any).

• With status: – specify the status of the object to be found. The values can 
be instrumented, sample trigger, sample_only, trigger_only, not-instrumented, or “*” 
(any). The default is “*” (any).

• Look in: – specify the location in the design hierarchy to begin the recur-
sive search. The root (“/”) is the default setting.

• In IICE: – a read-only field that indicates which IICE is to be searched 
when multiple IICEs are defined. To search another IICE, close the Find 
dialog box, click the desired IICE tab, and reopen the Find dialog box.

The search specification also includes a Show hidden elements check box. When 
this check box is enabled, the search also includes objects that would not 
normally be searched such as breakpoints in dead code.

Search Specification Search Results
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The search results window shows each object found along with its hierar-
chical location. In addition, for breakpoints and signals, the results window 
includes the corresponding icon (watchpoint or breakpoint) that indicates the 
instrumentation status of the qualified signal or breakpoint. 

To change the instrumentation status of a signal, click directly on the watch-
point icon and select the instrumentation type from the popup menu. You 
can use the Ctrl and Shift keys to select multiple signals and then apply the 
change to all of the selected signals. To toggle the instrumentation status of a 
breakpoint, click the breakpoint icon. You also can use the Ctrl and Shift keys 
to select multiple breakpoints and then apply the change to all selected 
breakpoints from the popup menu.

Console Text
To capture all text written to the console, use the log console command (see 
the reference manual). Alternately, you can click the right mouse button 
inside the console window and select Save Console Output from the menu.

To capture all commands executed in the console window use the transcript 
command (see the reference manual).

To clear the text from the console, use the clear command or click the right 
mouse button from within the console window and select Clear from the 
menu.
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C H A P T E R  7

Identify Debugger

The Identify debugger Actel Edition enables HDL designs to be debugged by 
interacting with the instrumented HDL design implemented in the target 
hardware system. You can activate breakpoints and watchpoints to cause 
trigger events within the IICE on the target device. These triggers cause signal 
data to be captured in the IICE. The data is then transferred to the Identify 
debugger through a JTAG port where it can be displayed in a variety of 
formats. 

This chapter describes:

• Invoking the Identify Debugger, on page 78

• Identify Debugger Windows, on page 79

• Commands and Procedures, on page 84

• Debugging on a Different Machine, on page 104

• Simultaneous Debugging, on page 105

• Waveform Display, on page 106

• Console Text, on page 108
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Invoking the Identify Debugger
The Identify debugger can be launched directly from a synthesis project or 
the Identify debugger can be explicitly opened directly from a Windows or 
Linux system.

Synthesis Tool Launch
If you are using a Synopsys FPGA synthesis tool, invoke the Identify debugger 
directly from the graphical user interface as follows:

• Highlight the Identify implementation

• Select Run->Launch Identify Debugger from the menu bar or popup menu, or 
click the Launch Identify Debugger icon in the top menu bar.

The Identify debugger IICE instrumentation window opens with the corre-
sponding project displayed (see Instrumentation Window, on page 80).

Operating System Invocation
The Identify debugger runs on both the Windows and Linux platforms. To 
explicitly invoke the debugger from a Windows system, either:

• double click the Identify Debugger icon on the desktop

• run identify_debugger.exe from the /bin directory of the installation path

To explicitly invoke the Identify debugger from a Linux system:

• run identify_debugger from the /bin directory of the installation path

The initial Identify debugger project window opens. To display the instrumen-
tation window, do either of the following:

• Click the Open existing project icon in the menu bar and, in the Open Project 
File dialog box, navigate to the synthesis project directory and open the 
corresponding prj file.

• Select File->Open project from the main menu and, in the Open Project File 
dialog box, navigate to the synthesis project directory and open the 
corresponding prj file.
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The Identify instrumentation (IICE) window opens with the corresponding 
project displayed (see Project Window, on page 82).

Identify Debugger Windows
The Graphical User Interface for the Identify debugger has three major areas:

• IICE instrumentation window

• Console window

• Project window

In this section, each of these areas and their uses are described. The 
following discussions assume that:

• a project (with an HDL design) has been loaded into the Identify instru-
mentor and instrumented

• the design has been synthesized in your synthesis tool

• the synthesized output netlist has been placed and routed by the place 
and route tool

• the resultant bit file has been used to program the FPGA with the 
instrumented design

• the board containing the programmed FPGA is cabled to your host for 
analysis by the Identify debugger
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Instrumentation Window
The instrumentation window in the Identify debugger, like the instrumenta-
tion window in the Identify instrumentor, includes a hierarchy browser on 
the left and the source code display on the right.

Hierarchy Browser

The hierarchy browser on the left shows a graphical representation of the 
design’s hierarchy. At the top of the browser is the ROOT node. The ROOT 
node represents the top-level entity or module of your design. For VHDL 
designs, the first level below the ROOT is the architecture of the top-level 
entity. The level below the top-level architecture for VHDL designs, or below 
the ROOT for Verilog designs, shows the entities or modules instantiated at 
the top level.

Hierarchy Browser Source-Code Display
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Clicking on a + sign opens the entity/module instance so that the hierarchy 
below that instance can be viewed. Lower levels of the browser represent 
instantiations, case statements, if statements, functional operators, and 
other statements.

Single clicking on any element in the hierarchy browser causes the associ-
ated HDL code to be displayed in the adjacent source code window.

Source Code Display

The source code display shows the HDL source code annotated with signals 
and breakpoints that were previously instrumented. 

Note: Signals and breakpoints that were not enabled in the Identify instru-
mentor are not displayed in the Identify debugger. 

Signals that can be selected for setting watchpoints are underlined, colored in 
blue, and have small watchpoint (or “P”) icons next to them. Breakpoints that 
can be activated have small green circular icons in the left margin to the left 
of the line number. 
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Selecting the watchpoint or “P” icon next to a signal (or the signal itself) 
allows you to select the Watchpoint Setup dialog box from the popup menu. This 
dialog box is used to specify a watchpoint expression for the signal. See 
Setting a Watchpoint Expression, on page 85.

Selecting the green breakpoint icon to the left of the source line number 
causes that breakpoint to become armed when the run command is executed. 
See Run Command, on page 91. 

Console Window
The Identify debugger console window displays commands that have been 
executed, including those executed by menu selections and button clicks. 
The Identify debugger console window also allows you to type Identify 
debugger commands and to view the results of command execution. 

Project Window
An empty project window is displayed when you explicitly start up the 
Identify debugger from the Windows or Linux platform. The window is 
replaced by the instrumentation window when the synthesis project (prj) file 
is read into the Identify debugger. 

The project window is restored at any time by clicking its tab at the bottom of 
the window.
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The project window displays the symbolic view of the project on the left and a 
Run button with a list of all of the available IICE units that can be debugged 
on the right. 
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Commands and Procedures
This section describes the typical operations performed in the Identify 
debugger.

Opening and Saving Projects
The Identify debugger commands to open and save projects are available as 
menu items and icons. 

See Chapter 3, Project Handling, for details on setting up and managing 
projects.

When opening a project that was saved with encrypted original sources, you 
are prompted to enter the original password used to encrypt the files. This 
password is then used to read any encrypted files. 

Setting the Working Directory
The working directory is used as the starting location for reading and writing 
files. Setting the working directory to the location of your project files makes 
working with the Identify debugger easier.

To set the working directory, select the File->Working directory menu selection 
and navigate to your project location.

Function Menu Bar
Icon

Menu Command

Open existing project File->Open project

Save current 
activations

File->Save activations
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Note: When importing a Synopsys FPGA synthesis project into the Identify 
debugger, the working directory is automatically set from the corre-
sponding project file.

Executing a Script File
A script file contains Identify Tcl commands and is a convenient way to 
capture a command sequence that you would like to repeat. To execute a 
script file, select the File->Execute Script menu selection and navigate to your 
script file location or use the source command (see Chapter 4, Alphabetical 
Command Reference, in the Reference Manual).

Activating/Deactivating an Instrumentation
The trigger conditions used to control the sampling buffer comprise break-
points, watchpoints, and counter settings (see Chapter 8, IICE Hardware 
Description). Activation and deactivation of breakpoints and watchpoints are 
discussed in this chapter.

Setting a Watchpoint Expression

Any signal that has been instrumented for triggering can be activated as a 
watchpoint in the Identify debugger. A watchpoint is defined by assigning it 
one or two HDL constant expressions. When a watched signal changes to the 
value of its watchpoint expression, a trigger event occurs.

A watchpoint is set on a signal by clicking-and-holding on the signal 
or the watchpoint icon next to the signal and then selecting the Set 
Trigger Expressions menu item to bring up the Watchpoint Setup dialog 
box.

A watchpoint is set on a partial bus signal by clicking-and-holding 
on the signal or the “P” icon next to the signal, selecting the partial 
bus group from the list displayed, and then selecting the Set Trigger 
Expressions menu item to bring up the Watchpoint Setup dialog box.

There are two forms of watchpoints: value and transition. 
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• A value watchpoint triggers when the watched signal attains a specific 
value.

• A transition watchpoint triggers when the watched signal has a specific 
value transition.

To create a value watchpoint, assign a single, constant expression to the 
watchpoint. A value watchpoint triggers when the watched signal value 
equals the expression. In the example below, the signal is a 4-bit signal, and 
the watchpoint expression is set to “0010.” Any legal VHDL or Verilog (as 
appropriate) constant expression is accepted.

To create a transition watchpoint, assign two constant expressions to the 
watchpoint. A transition watchpoint triggers when the watched signal value 
is equal to the first expression during a clock period and the value is equal to 
the second expression during the next clock period. In the example below, the 
transition being defined is a transition from “0010” to “1011.”

The VHDL or Verilog expressions that are entered in the Watchpoint Setup 
dialog box can also contain “X” values. The “X” values allow the value of some 
bits of the watched signal to be ignored (effectively, “X” values are don’t-care 



Commands and Procedures Chapter 7: Identify Debugger

Identify Actel Edition User Guide Copyright © 2011 Synopsys, Inc.
March 2011 87

values). For example, the above value watchpoint expression can be specified 
as “X010” which causes the watchpoint to trigger only on the values of the 
three right-most bits.

Clicking OK on the Watchpoint Setup dialog box activates the watchpoint (the 
“watch” or “P” icon changes to red) which then is armed in the hardware the 
next time the Run button is pressed.

Deactivating a Watchpoint

By default, a watchpoint that does not have a watchpoint expression is 
inactive. A watchpoint that has a watchpoint expression can be temporarily 
deactivated. A deactivated watchpoint retains the expression entered, but is 
not armed in the hardware and does not cause triggers. 

To deactivate a watchpoint, click-and-hold on the signal or the 
associated watchpoint icon. The watchpoint popup menu appears. 

To deactivate a partial-bus watchpoint, click-and-hold on the signal 
or the associated “P” icon and select the bus segment from the list of 
segments displayed. The watchpoint popup menu appears.

The Watch menu selection will have a check mark to indicate that the watch-
point is activated. Click on the Watch menu selection to toggle the check mark 
and deactivate the watchpoint.

Reactivating a Watchpoint

To reactivate an inactive watchpoint, click-and-hold on the signal or the 
associated watchpoint or “P” icon. Clicking the watchpoint icon redisplays the 
watchpoint popup menu: clicking the “P” icon, lists the partial bus segments; 
select the bus segment from the list displayed to display the watchpoint 
popup menu. Click on the Watch menu selection to toggle the check mark and 
reactivate the watchpoint.
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Activating a Breakpoint

Instrumented breakpoints are shown in the Identify debugger as green icons 
in the left margin adjacent to the source-code line numbers. Green break-
point icons are inactive breakpoints, and red breakpoint icons are active 
breakpoints. To activate a breakpoint, click on the icon to toggle it from green 
to red.

To deactivate an active breakpoint, click on the breakpoint icon to toggle it 
from red to green.

Activating/Deactivating Folded Instrumentation
If your design contains entities or modules that are instantiated more than 
once, the design is termed to have a “folded” hierarchy (folded hierarchies 
also occur when multiple instances are created within a generate loop). By 
definition, there will be more than one instance of every signal and break-
point in a folded entity or module. During instrumentation, it is possible to 
instrument more than one instance of a signal or breakpoint.

When debugging an instrumented design with multiple instrumented 
instances of a breakpoint or signal, the Identify debugger allows you to 
activate/deactivate each of these instrumented instances independently. 
Independent selection is accomplished by displaying a list of the instru-
mented instances when the breakpoint or signal is selected for activa-
tion/deactivation.

Inactive breakpoint (green)

Active breakpoint (red)
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Activating/Deactivating a Folded Watchpoint

The following example consists of a top-level entity called folded2 and two 
instances of the repeated_unit entity. The source code of repeated_unit is 
displayed. In this folded entity, multiple instances of the signal val and the 
breakpoint at line 24 (not shown) are instrumented. 

To activate/deactivate instances of the val signal, select the watchpoint icon 
next to the signal. A list will pop up with the two instrumented instances of 
the signal val available for activation/deactivation: 

/rtl/cnt_inst0/val
/rtl/cnt_inst1/val

Either of these instances is activated/deactivated by clicking on the appro-
priate line in the list box to bring up the watchpoint menu shown in the 
following figure.

The color of the watchpoint icon is determined as follows:

• If no instances of the signal are activated, the watchpoint icon is green 
in color.

• If some, but not all, instances of the signal are activated, the watchpoint 
icon is yellow in color. 

• If all instances are activated, the watchpoint icon is red in color.

For related information on folded hierarchies, see Sampling Signals in a 
Folded Hierarchy, on page 65 and Displaying Data from Folded Signals, on 
page 96.



LO

Chapter 7: Identify Debugger Commands and Procedures

Copyright © 2011 Synopsys, Inc. Identify Actel Edition User Guide
90 March 2011

Activating/Deactivating a Folded Breakpoint

To activate/deactivate instances of the breakpoint on line 24, select the icon 
next to line number 24. A list will pop up with the two instrumented 
instances of the breakpoint available for activation/deactivation: 

/rtl/inst0/rtl/process_18/if_20/if_23/repeated_unit.vhd:24
/rtl/inst1/rtl/process_18/if_20/if_23/repeated_unit.vhd:24

Either of these instances can be activated/deactivated by clicking on the 
appropriate line in the list box.

The color of the breakpoint icon is determined as follows:

• If no instances of the breakpoint are activated, the breakpoint icon is 
green.

The list of instrumented instances
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• If some, but not all, instances of the breakpoint are activated, the break-
point icon is yellow. 

• If all instances are activated, the breakpoint icon is red.

Run Command
The Run command sends watchpoint and breakpoint activations to the IICE, 
waits for the trigger to occur, receives data back from the IICE when the 
trigger occurs, and then displays the data in the source window.

To execute the Run command for the active IICE (or a single IICE), 
select Debug->Run from the menu or click the Arm current IICE for 
triggering icon. To execute the Run command for multiple IICE units, 

open the project window (click the project window tab), enable the individual 
IICE units by checking their corresponding boxes, and either click the large 
Run button or select Debug->Run from the menu.

After the Run command is executed, the sample of signal values at the trigger 
position is annotated to the HDL code in the source code window. This data 
can be displayed in a waveform viewer (see the Identify debugger waveform 
command) or written out to a file (see the Identify debugger write vcd 
command).

Note: In a multi-IICE environment, you can edit and run other IICEs while 
an IICE is running. The icons within the individual IICE tabs indicate 
when an IICE is running (rotating arrow) and when an IICE has new 
sample data (green check mark).
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The following example shows a design with one breakpoint activated, the 
breakpoint triggered, and the sample data displayed. The small green arrow 
next to the activated breakpoint in the example indicates that this breakpoint 
was the actual breakpoint that triggered. Note that the green arrow is only 
present with simple triggering.

Sample Buffer Trigger Position
The purpose of the activated watchpoints and breakpoints is to cause a 
trigger event to occur. The trigger event causes sampling to terminate in a 
controlled fashion. Once sampling terminates, the data in the sample buffer 
is communicated to the Identify debugger and then displayed in the GUI.

The sample buffer is continuously sampling the design signals. Conse-
quently, the exact relationship between the trigger event and the termination 
of the sampling can be controlled by the user. Currently, the Identify 
debugger supports the following trigger positions relative to the sample 
buffer:

• Early

• Middle

• Late

Activated and triggered breakpoint Sampled data (in yellow)
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Determining the correct setting for the trigger position is up to the user. For 
example, if the design behavior of interest usually occurs after a particular 
trigger event, set the trigger position to “early.”

The trigger position can be changed without requiring the design to be 
reinstrumented or recompiled. A new trigger position setting takes effect the 
next time the Run command is executed. 

Early Position

The sample buffer trigger position can be set to “early” so that the 
majority of the samples occurs after the trigger event. To set the 
trigger position to “early,” use the Debug->Trigger Position->early menu 
selection or click on the Set trigger position to early in the sample buffer icon.

Middle Position

The sample buffer trigger position defaults to “middle” so that there is 
an equal number of samples before and after the trigger event. To set 
the trigger position to “middle,” use the Debug->Trigger Position->middle 
menu selection or click on the Set trigger position to middle in the sample 
buffer icon.

Late Position

The sample buffer trigger position can be set to “late” so that the 
majority of the samples occurs before the trigger event. To set the 
trigger position to “late,” use the Debug->Trigger Position->late menu 
selection or click on the Set trigger position to late in the sample buffer icon.

Stop Command
The Stop command sends control back to the Identify debugger after 
you have armed the trigger, but before the trigger occurs. The Stop 
command can be executed by selecting Debug->Stop from the menu or 
by clicking the Stop debugging hardware icon.
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Note: If you are running the IICE from the project window using the Run 
button and IICE check boxes (multi-IICE mode), you can stop a run 
by clicking the STOP icon adjacent to the check box.

Sampled Data Display Controls
The sampled data display controls are used to navigate through the data 
values captured by the sample buffer. All sample buffer data is tagged with a 
cycle number based on when the data item was stored in the sample buffer 
relative to the trigger event. The data item stored at the trigger event time has 
cycle number 0, the data item stored one sample clock cycle after the trigger 
has cycle number 1, and the data item stored one sample clock cycle before 
the trigger has cycle number -1. The data display procedures allow you to 
retrieve data values for a specific cycle number.

The sampled data displayed in the Identify debugger is controlled by the Cycle 
text field. You can manually change the cycle number by typing a number in 
the entry field. Also, the up and down arrows to the right of the cycle number 
increment or decrement the cycle number for each click.

To reset the cycle number to the default position (the zero time 
position), use the Debug->Cycle->home menu selection or click on the 
Goto trigger event in sample history icon.

Sampled data 
display controls
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Radix

The radix of the sampled data displayed can be set to any of a number of 
different number bases. To change the radix of a sampled signal:

1. Right click on the signal name or the “watch” or “P” icon and select 
Change signal radix to display the following dialog box.

2. Click the corresponding radio button.

3. Click OK.

Note: You can change the radix before the data is sampled. The watchpoint 
signal value will appear in the specified radix when the sampled data 
is displayed.

Specifying default resets the radix to its initial intended value. Note that the 
radix value is maintained in the “activation database” and that this informa-
tion will be lost if you fail to save or reload your activation. Also, the radix set 
on a signal is local to the Identify debugger and is not propagated to any of 
the waveform viewers.

Note: Changing the radix of a partial bus changes the radix for all bus 
segments.
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Displaying Data from Folded Signals
If your design contains entities or modules that are instantiated more than 
once, it is termed to have a “folded” hierarchy (folded hierarchies also occur 
when multiple instances are created within a generate loop). By definition, 
there will be more than one instance of every signal in a folded entity or 
module. During instrumentation, it is possible to instrument more than one 
instance of a signal. 

When debugging an instrumented design with multiple instrumented 
instances of a signal, the Identify debugger allows you to display the data 
values of each of these instrumented signals.

Because multiple data values cannot be displayed at the same location, a 
single data value is always displayed. For multiply instrumented signals, the 
Identify debugger displays an ellipsis (...) to indicate that there are multiple 
values present. To display all of the instrumented values, click-and-hold on 
the ellipsis indicator.

The example below consists of a top-level entity called top and two instances 
of the repeated_unit entity. In the example, the source code of repeated_unit is 
displayed, and both of the lists of instances of the signal val have been instru-
mented. The two instances are /rtl/inst0/val and /rtl/inst1/val, and their data values 
are displayed in the pop-up window as shown in the following figure:

For related information on folded hierarchies, see Sampling Signals in a 
Folded Hierarchy, on page 65 and Activating/Deactivating Folded Instrumen-
tation, on page 88.

Indicator of folded data Data values for instances of folded signal val
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Displaying Data for Partial Buses
When debugging designs with partially instrumented buses, the Identify 
debugger displays the data values of each of the instrumented segments.

To display the instrumented values for the individual bus segments, position 
the cursor over the composite bus value. The individual partial bus values 
are displayed in a tooltip in the specified radix as shown in the following 
figure. 

Note that in the above figure, the question marks (?) in the composite bus 
value (64' h3fad7910d1????36) indicate that the corresponding segment (data_in 
[23:8]) has not been instrumented.

Displaying Data for Partial Instrumentation
In the Identify debugger, the value for a fully instrumented record or struc-
ture is shown with a value for each field, in field order. The following figure 
shows instrumented signal sig_iport_P_Struc_instr. When displaying a partially 
instrumented bus, the value U is used for the uninstrumented slices. This 
same notation is used to show the data values for a partially instrumented 
record or structure (the value for each instrumented field is listed in field 
order, and an uninstrumented field value is shown as a U).

Composite bus value Data values of partial buses
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The Find dialog in the Identify debugger shows a partially instrumented signal 
with the P icon. You can set the trigger expressions on the fields instru-
mented for triggering in the same manner as if the signal was fully instru-
mented (i.e., select the signal, right click to bring up the dialog, and select the 
option to set the trigger expression).

Saving and Loading Activations
The Identify debugger includes a “capture and replay” function that allows 
you to save and load a set of enabled watchpoints and breakpoints referred to 
collectively as an “activation.” Each activation can additionally include the 
sample data set that was captured for a given trigger condition. Activations 
are stored in files with an adb extension in a project’s instrumentation subdi-
rectory.

Saving an Activation

An activation can be explicitly saved or saved on exit. To explicitly save an 
activation:

1. Enable the set of watchpoints and breakpoints for the activation.

2. If the sample data set is to be included, run the Identify debugger to 
collect the sample data.
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3. Select File->Save activations or click the Save current activations icon in the 
menu bar to bring up the following dialog box.

4. Enter (or select) an activation name in the Save current trigger settings as: 
field. Selecting an existing activation from the drop-down menu 
overwrites the selected activation.

5. To include the sample data set with the activation, enable the Save 
current sample data checkbox.

6. Click Yes to save the activation.

Loading an Activation

To load an existing activation:

1. Open the project view.

2. Expand (if necessary) the hierarchy to display the list of activations as 
shown in the figure below.

3. Click on the desired activation and select Load activation.
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Autosaving Current Activation

By default, when you exit the Identify debugger without explicitly saving an 
activation, the active activation is automatically saved to the last_run.adb file. 
This file is automatically loaded the next time you open the project.

Note: To save a specific activation, always use Save current activations to 
explicitly name the file and prevent the data from overwriting the 
last_run.adb file.

To disable the auto-save feature, uncheck the Auto-save trigger settings and 
sample results check box on the Debugger Preferences dialog box (select 
Options->Debugger preferences).

Cross Triggering
Cross triggering allows the trigger from one IICE unit to be used to qualify a 
trigger on another IICE unit, even when the two IICE units are in different 
time domains. Cross triggering is available in both the simple triggering and 
complex counter triggering modes (state-machine triggering supports cross 
triggering by allowing the IICE unit IDs to be included in the state-machine 
equations).
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Cross triggering for an IICE unit is enabled in the Identify instrumentor by 
selecting the Allow cross-triggering in IICE check box on the IICE Controller tab for 
the local IICE unit. The cross-trigger mode is selected from the drop-down 
menu in the Identify debugger shown below.

The drop-down menu selections are as follows:

Note: If the drop-down menu does not display, make sure that Allow cross-
triggering in IICE is enabled on the IICE Controller tab of the Identify 
instrumentor and that you have defined more than one IICE unit.

Menu Selection Function

disabled No triggers accepted from external IICE units (event trigger can 
only originate from local IICE unit)

any Event trigger from local IICE unit occurs when an event at any 
IICE unit, including the local IICE unit, occurs

all Event trigger from local IICE unit occurs when all events, 
irrespective of order, occur at all IICE units including the local 
IICE unit

after-iiceName Event trigger from local IICE unit occurs only after the event at 
selected external IICE unit iiceName has occurred (external IICE 
units are individually listed) 

after all Event trigger from local IICE unit occurs after all events occur 
at all IICE units
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Remote Triggering
Remote triggering allows one debugger executable to send a software trigger 
event to terminate data collection in the other debugger executables, effec-
tively creating a remote stop button. 

You can selectively set the remote trigger to:

• trigger all IICEs in all debugger executables

• trigger all IICEs in a specific debugger executable

• trigger a specific IICE in a specific debugger executable

A common design configuration when using multiple FPGAs is to trigger all 
FPGAs on a single board-level event; when that event occurs, data collection 
is stopped and the sample data is downloaded by the corresponding debugger 
executables for all FPGAs.

Remote triggering is a scripting application. The IICE/debugger targets are 
defined by the Identify debugger remote_trigger command (see the command 
description in the Reference Manual). As an example, the scripting sequence

run ; remote_trigger -pid 12

waits for the trigger condition in the current IICE and then sends a trigger to 
all IICE units in the debugger executable identified by process ID 12.

List All Watchpoints
To list all watchpoints, use the Debug->Show All Watchpoints menu selection. The 
result of listing the signals is displayed in the console window.

List Inactive Watchpoints
To see the inactive watchpoints, click the Show disabled watchpoints 
icon. The result of listing the signals is displayed in the console 
window.
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List Active Watchpoints
To see the active watchpoints, click the Show enabled watchpoints icon. 
The result of listing the signals is displayed in the console window.

List All Breakpoints
To list all breakpoints, use the Debug->Show All Breakpoints menu selection. The 
result of listing the signals is displayed in the console window.

List Inactive Breakpoints
To see the inactive breakpoints click the Show disabled breakpoints icon. 
The result of listing the signals is displayed in the console window.

List Active Breakpoints
To see the active breakpoints, click the Show enabled breakpoints icon. 
The result of listing the signals is displayed in the console window.
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Debugging on a Different Machine
It is not unusual for the instrumentation phase and the debugging phase to 
be performed on different machines. For example, the debug machine is often 
located in a hardware lab. When a different machine is used for debugging, 
you must copy both the project file (projectName.prj) and the Identify imple-
mentation directory (e.g., rev_1) to the lab machine.

Because the Identify tool set allows you to debug your design in the HDL, the 
Identify debugger must have access to the original source files. Depending on 
the type of your network, the Identify debugger may be able to access the 
original sources files directly from the lab machine. If this is not possible or if 
the two computers are not networked, you must also transfer the original 
sources to the debug machine. If the Identify debugger cannot locate the 
original source files, it will open the project, but an error will be generated for 
each missing file, and the corresponding source code will not be visible in the 
source viewer.

Copying the source files to the debug machine can be done in two ways:

• Identify can automatically include the original source files in the imple-
mentation directory so that when you copy the implementation directory 
to the lab machine, the original sources files (in the orig_sources subdi-
rectory) are included. The Identify debugger automatically looks in this 
directory for any missing source files. This preference is set before 
compiling the instrumented design by selecting Options->Instrumentation 
preference and making sure that Save original source in instrumentation directory 
is checked.

• The original source files can be manually copied to the lab machine or 
may already exist in a different location on this machine. In this case, it 
may be necessary to help Identify find the design files using the search-
path command. Simply call this command from the command line before 
loading the project file (projectName.prj). The argument is a semi-colon-
separated (Windows) or colon-separated (Linux) list of directories in 
which to find the original source files. 

searchpath {d:/temp;c:/Documents and Settings/me/my_design/}
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The Identify debugger will only display files that match the CRC generated at 
the time of instrumentation.

Note: If there are security issues with having the original source files on the 
lab machine, the Identify instrumentor can password-protect the 
original sources on the development machine for use with the Identify 
debugger (for information on file encryption, see Including Original 
HDL Source, on page 70).

Simultaneous Debugging
When multiple Identify debugger licenses are available, multiple FPGAs 
residing on a single, non-HAPS board can be debugged concurrently through 
a single cable. This capability is based on semaphores that allow more than 
one debugger to share the port.

Board

 

FPGA1 FPGA2

Cable

Semaphore
pid1

pid2

Debugger 1

Debugger 2

PID1

PID2
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Waveform Display
The waveform display control displays the sampled data in a waveform style. 
By default, this feature uses the waveform display capabilities of the 
GTKWave freeware waveform viewer. Provision for using other popular 
waveform viewers that support VCD data is included. Alternately, you can 
interface your own waveform viewer by writing a customized script to access 
your waveform viewer from the Identify debugger. For details, see the applica-
tion note, “Interfacing Your Waveform Viewer with the Identify Debugger” on 
the SolvNet website.

Viewer selection and setup are controlled by the Waveform Viewer Preferences 
dialog box. Selecting Options->Waveform preference from the menu bar brings up 
the dialog box shown below.

The GTKWave viewer is selected by default; to use the other viewers, they 
must be installed and included in the search path as outlined below:

1. Open the Debugger Preferences dialog box (select Options->Waveform 
preferences).
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2. Select the desired waveform viewer by clicking the adjacent radio button 
and then click OK. 

3. Make sure that the selected simulator is installed on to your machine 
and that the path to the executable is set by your $PATH environment 
variable.

4. To invoke the viewer after running the Identify debugger, select 
Window->Waveform or click on the Open Waveform Display icon.

The Period field sets the period for the waveform display and is independent of 
the design speed.

After running the Identify debugger, the waveform viewer is displayed 
by selecting Window->Waveform from the menu or by clicking the Open 
Waveform Display icon in the menu bar. All sampled signals in the 

design are included in the waveform display. Two additional signals are 
automatically added to the top of the display. The first signal, identify_cycle, 
reflects the trigger location in the sample buffer. The second signal, 
identify_sampleclock, is a reference that shows every clock edge. The following 
figure shows a typical waveform view with the identify_cycle and 
identify_sampleclock highlighted.

If you select a waveform viewer from the Waveform preference dialog box that is 
not installed, an error message is displayed when you attempt to invoke the 
viewer. 
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Console Text
To capture all the text that is written to the console, use the log console 
command (see the reference manual). Alternately, you can click the right 
mouse button inside the console window and select Save Console Output from 
the menu. To capture all commands executed in the console window, use the 
transcript command (see the reference manual).

To clear the text in the console window, use the clear command or click the 
right mouse button inside the console window and select clear from the menu.
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C H A P T E R  8

IICE Hardware Description

The Identify instrumentor adds instrumentation logic to your HDL design 
that allows you to understand and debug the operation of your design. There 
are some aspects of the instrumentation logic that are important to under-
stand in order to use the Identify tool set in the most effective way. In this 
chapter, the overall instrumentation logic is described briefly followed by 
descriptions of some of the more important features. A simplified functional 
breakdown of the instrumentation logic consists of:

• JTAG Communication Block

• Breakpoint and Watchpoint Blocks

• Sampling Block

• Complex Counter

• State Machine Triggering

JTAG Communication Block
The JTAG communication block can be implemented using either the built-in 
device-specific TAP controller (the builtin option) or using the Identify imple-
mentation of the TAP controller (the soft option). See Chapter 9, Connecting to 
the Target System, for more information on the JTAG controller.
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Breakpoint and Watchpoint Blocks
The following topic are described in this section:

• Breakpoints

• Watchpoints, on page 111

• Multiple Activated Breakpoints and Watchpoints, on page 111

Breakpoints
Breakpoints are a way to easily create a trigger that is determined by the flow 
of control in the design. 

In both Verilog and VHDL, the flow of control in a design is primarily deter-
mined by if, else, and case statements. The control state of these statements is 
determined by their controlling HDL conditional expressions. Breakpoints 
provide a simple way to trigger when the conditional expressions of one or 
more if, else, or case statements have particular values. 

The example below shows a VHDL code fragment and its associated break-
points.

 99 process(op_code, cc, result) begin 
100   case op_code is
101     when "0100" =>
102       result <= part_res;
103       if cc = '1' then
104          c_flag <= carry;
105          if result = zero then
106             z_flag <= '1';
107          else
108             z_flag <= '0';
109          end if;
110       end if;
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The four breakpoints correspond to these control flow equations:

• Breakpoint at line number 102: 

(op_code = "0100")

• Breakpoint at line number 104: 

(op_code = "0100") and (cc = '1')

• Breakpoint at line number 106: 

(op_code = "0100") and (cc = '1') and (result = zero)

• Breakpoint at line number 108: 

(op_code = "0100") and (cc = '1') and (result != zero)

Watchpoints
A watchpoint creates a trigger that is determined by the state of a signal in 
the design. The watchpoint can trigger either on the value of a signal or on a 
transition of a signal from one value to another.

Multiple Activated Breakpoints and Watchpoints
How breakpoints and watchpoints operate individually has been described 
earlier in this guide. Activated breakpoints and watchpoints also interact with 
each other in a very specific way.

Multiple Activated Breakpoints

Each breakpoint is implemented as logic that watches for a particular event 
in the design. When an instrumented design has more than one activated 
breakpoint, the breakpoint events are ORed together. This effectively allows 
the breakpoints to operate independently – only one activated breakpoint 
must trigger in order to cause the sampling buffer to acquire its sample.
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Multiple Activated Watchpoints

Each watchpoint is implemented as logic that watches for a specific event 
consisting of a bit pattern or transition on a specific set of signals. When an 
instrumented design has more than one activated watchpoint, the watch-
point events are ANDed together. This effectively causes the watchpoints to 
be dependent on each other – all activated watchpoint events must occur 
concurrently to cause the sampling buffer to acquire its sample.

For example, if watchpoint 1 implements (count == 23) and watchpoint 2 
implements (ack == ‘1’), then activating these watchpoints together effectively 
creates a new watchpoint: (count == 23) && (ack == ‘1’).

Combining Activated Breakpoints and Watchpoints

When an instrumented design has one or more activated breakpoints and 
one or more activated watchpoints, the result of the OR of the breakpoint 
events and the result of the AND of the watchpoint events is ANDed together. 
The result of this AND operation is called the Master Trigger Signal. This 
ANDing effectively causes the breakpoints and watchpoints to be dependent 
on each other – one activated breakpoint and all activated watchpoint events 
must occur concurrently to cause the sampling buffer to acquire its sample.

As a result, a Master Trigger Signal event can be constructed that operates 
like a conditional breakpoint. For example, activating a breakpoint and the 
two watchpoints from the previous example produces a conditional break-
point: (breakpoint event) && (count== 23) && (ack == ‘1’).

Sampling Block
The sampling block is basically a large memory used to store all the sampled 
signals. During an active debugging session, the sampled signals are contin-
ually being stored in the sample block. When the sample block receives an 
event from the Master Trigger Signal event logic or the complex counter logic, 
the sampling block stops writing new data to the buffer and holds its 
contents. Eventually, the contents of the sample block are uploaded to the 
Identify debugger for display and formatting.
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Whenever possible, the sample block should use the built-in RAM blocks that 
are available in most programmable chips. Otherwise, implementing the 
sample buffer using individual storage elements will consume large amounts 
of the logic capacity of the chip. If you have no choice but to use individual 
storage elements, analyze how much logic you have available on your chip 
and adjust how many signals you sample and the depth of the sample buffer.

Complex Counter
The complex counter connects the output of the breakpoint and watchpoint 
event logic to the sampling block and allows the user to implement complex 
triggering behavior.

Creating a Complex Counter
The counter is created, configured, and inserted into the HDL design during 
instrumentation using the Identify instrumentor IICE Controller tab of the IICE 
Configuration dialog box or using the Identify instrumentor iice controller 
command.

During configuration, the size of the counter is specified. For example, a 16-
bit counter is the default. This default value produces a counter that ranges 
from 0 to 65535.

Setting the counter size to zero during instrumentation configuration 
disables counter insertion.

Debugging with the Complex Counter
During debugging in the Identify debugger, the complex counter is used to 
produce complex triggering behavior. 

During the debugging of the design, the complex counter is set to zero on 
invocation of the Identify debugger run command. Then, it counts events from 
the Master Trigger Signal event logic in a specific way depending on the 
counter mode. 
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Finally, the counter sends a trigger event to the sample block when a termi-
nation condition occurs. The form of the termination condition depends on 
the mode of operation of the counter and on the target value of the counter:

• The counter target value can be set to any value in the counter’s range. 

• The counter has four modes: events, cycles, watchdog, and pulsewidth.

The counter target value and the counter mode can be set directly from the 
the main menu.

The following table provides a general description of the trigger behavior for 
the various complex counter modes. Each mode is described in more detail in 
individual subsections, and examples are included showing how the modes 
are used. In both the table and subsection descriptions, the counter target 
value setting is represented by the symbol n.

Counter mode Target value = 0 Target value n > 0

events illegal stop sampling on the nth trigger 
event.

cycles stop sampling on 1st 
trigger event

stop sampling n cycles after the 
1st trigger event.

watchdog illegal stop sampling if the trigger 
condition is not met for n 
consecutive cycles.

pulsewidth illegal stop sampling the first time the 
trigger condition is met for n 
consecutive cycles.
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events Mode

In the events mode, the number of times the Master Trigger Signal logic 
produces an event is counted. When the nth Master Trigger Signal event 
occurs, the complex counter sends a trigger event to the sample block. For 
example, this mode could be used to trigger on the 12278th time a collision 
was detected in a bus arbiter.

cycles Mode

In the cycles mode, the complex counter sends a trigger event to the sample 
block on the nth cycle after the first Master Trigger Signal event is received. 
The clock cycles counted are from the clock defined for sampling. For 
example, this mode could be used to observe the behavior of a design 
2,000,000 cycles after it is reset.

watchdog Mode

In the watchdog mode, the counter sends a trigger event to the sample block 
if no Master Trigger Signal events have been received for n cycles. For 
example, if an event is expected to occur regularly, such as a memory refresh 
cycle, this mode triggers when the expected event fails to occur.

pulsewidth Mode

In the pulsewidth mode, the complex counter sends a trigger event to the 
sample block if the Master Trigger Signal logic has produced an event during 
each of the most recent n consecutive cycles. For example, this mode can be 
used to detect when a request signal is held high for more than n cycles 
thereby detecting when the request has not been serviced within a specified 
interval.

Disabling the Counter
According to the previous table, the counter can be disabled simply by setting 
its target value to 1 and its mode to events. Then, the complex counter will 
pass any received event from the Master Trigger Signal logic on to the sample 
block with no additional delay.
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State Machine Triggering
This section describes the different methods of triggering available in the 
Identify debugger. It explains the different choices available during instru-
mentation and the functionality these choices provide in the Identify 
debugger as well as discussing the cost effects of the various types of instru-
mentation.

Simple or Advanced Triggering
There are two triggering modes available, the simple mode and the advanced 
mode. The simple mode allows comparing signals to values (including don’t 
cares) and then triggering when the signals match those values. This scheme 
can be enhanced by using breakpoints to denote branches in control logic. If 
a breakpoint is enabled, this particular branch must be active at the same 
time that the signals match their respective values. The overall trigger logic 
involves signals and breakpoints in the following way:

• Signals: All signals must match their respective comparison values in 
order to trigger.

• Breakpoints: All breakpoints are OR connected, meaning that any one 
enabled breakpoint is enough to trigger.

• Signals and breakpoints are combined using AND, such that all signals 
must match their values AND at least one enabled breakpoint must 
occur.

The logic that implements breakpoint and signal triggering is referred to as 
trigger condition (condition) in the following text.

In the advanced trigger mode, multiple such trigger conditions are instru-
mented, and a runtime-programmable state machine is also instrumented to 
allow you to specify the temporal and logical behavior that combines these 
trigger conditions into a complex trigger function. For instance, this state 
machine enables you to trigger on a certain sequence of events like “trigger if 
pattern A occurs exactly five cycles after pattern B, but only if pattern C does 
not intervene.”

By default, the Identify instrumentor instruments the design according to the 
simple trigger mode. See the following for more information on how to select 
the advanced trigger mode.
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Advanced Triggering Mode
Setting up an instrumented design to enable advanced triggering is extremely 
easy. There are two iice controller command options available in the Identify 
instrumentor that control the extent and cost of the instrumentation:

• -triggerconditions integer – The integer argument to this option defines 
how many trigger conditions are created. All these trigger conditions are 
identical in terms of signals and breakpoints connected to them, but 
they can be programmed separately in the Identify debugger.

• -triggerstates integer – The integer argument to this option defines how 
many states the trigger state machine will have. Powers of 2 are prefer-
able as other numbers limit functionality and do not provide any cost 
savings.

Similar to the simple-triggering mode, a counter can be instrumented to 
augment the functionality of the state machine. To instrument a counter, 
enter an iice controller -counterwidth option with an argument greater than 0 in 
the Identify instrumentor console window.

Please refer to the following text to determine cost and consequences of these 
settings in the Identify instrumentor.

Structural Implementation of State Machine Triggering

For each trigger condition ci, a logic cone is implemented which evaluates the 
signals and breakpoints connected to the trigger logic and culminates in a 
1-bit result identical to the trigger condition in simple mode. All these 1-bit 
results are connected to the address inputs of a RAM table.

If a counter has been added to the instrumentation, the counter output is 
compared to constant 0, and the single-bit output of that comparison is also 
connected to the address inputs of the same RAM table.

The other address inputs are provided by the state register.

The outputs of the RAM table are:

• the next-state value nstate

• the trigger signal trigger (causes the sample buffer to take a snapshot if 
high)

• the counter-enable signal cnten (if ‘1’, counter is decremented by 1)
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• the counter-load signal cntld (if ‘1’, counter is loaded with cntval)

• the counter value cntval (only useful in conjunction with cntld)

The last three outputs are only present if a counter was instrumented. Please 
also refer to the figure below.

The implementation of the RAM table is identical to the implementation of the 
sample buffer (i.e., the device buffertype setting selects the implementation of 
both the sample buffer and the state machine RAM table).

Cost Estimation

The most critical setting with respect to cost is the number of trigger condi-
tions, as each trigger condition results in an additional address bit on the 
RAM, and thus doubles the size of the RAM table with each bit. Next in 
importance is the counter width as this factor contributes directly to RAM 
table width and is especially significant in the context of FPGA RAM primi-
tives that allow a trade-off of width for depth.

trigger
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state

cntnull
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The actual instrumentation, however, is not limited to the values provided, 
nor is it limited to the usage of a single blockRAM (for example, it may be 
advantageous in a particular situation to trade away states for additional 
trigger conditions, or for additional counter width). Any configuration can be 
automatically implemented, as long as it fits on the device with the rest of the 
design.

There is no need to deal with the specific RAM parameters, since these are 
automatically determined by the Identify instrumentor, but it is good to 
monitor this information to make sure that no resources are wasted.

Using State Machine Triggering in the Identify Debugger

Perform the following steps in the Identify debugger console window to setup 
a trigger in advanced triggering mode. These steps can be done in any order.

• setup of the values for the trigger conditions using the Identify debugger 
watch and stop commands.

• setup of the trigger state machine behavior using the Identify debugger 
statemachine command.

The watch command takes an additional parameter, -condition, specifying the 
trigger conditions that the given condition is intended for. That argument is 
available in simple mode as well, but as there is only one trigger condition in 
this case, it is redundant.

• watch enable -condition (triggerCondition|all) signalName value1 [value2 ...]

• watch disable -condition (triggerCondition|all) signalName

• watch info [-raw] signalName

The parameter triggerCondition is a list value conforming to the Tcl language. 
Examples are: 1, "1 2 3", {2 3}, or [list 1 2 3], quotes, braces, and 
brackets included, respectively. Alternatively, the keyword all can be specified 
to apply the setting to all trigger conditions.

The Identify debugger watch info command reports status information about 
the signal. This information is returned in machine-processible form if the 
optional parameter -raw is specified.

Similarly for the Identify debugger stop command:

• stop enable -condition (triggerCondition |all) breakpoint

• stop disable -condition (triggerCondition |all) breakpoint
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• stop info [-raw] breakpoint

The semantics of the parameters are identical to the above description.

The statemachine Command

During instrumentation, the number of states was previously defined using 
the -triggerstates option of the Identify instrumentor iice controller command. 
Now, at debug time, you can define what happens in each state and transi-
tion depending on the pattern matches computed by the trigger conditions. 
The Identify debugger statemachine command is used to configure the trigger 
state machine with the desired behavior. This is very similar to the 
“advanced” trigger mode offered by many logic analyzers. As it is very easy to 
introduce errors in the process of specifying the state machine, special 
caution is appropriate. Also, a state-machine editor is available in the Identify 
debugger user interface to facilitate state-machine development and under-
standing (see State-Machine Editor, on page 126). It is also important to note 
that the initial state for each run is always state 0 and that not all of the 
available states need to be defined.

The syntax forms of the Identify debugger statemachine command are:

• statemachine addtrans -from state [-to state] [-cond "equation|titriggerInID"]
[-cntval integer] [-cnten] [-trigger]

• statemachine clear (-all|state [state ...])

• statemachine info [-raw] (-all|state [state ...])

Subcommand statemachine addtrans

The Identify debugger addtrans subcommand defines the transitions between 
the states. The options are as follows:

• -from state – specifies the state this transition is exiting from.

• -to state – specifies the state this transition goes to. If this is not given, it 
defaults the state given in the -from option.

• -cond "equation|titriggerInID" – specifies the condition or external trigger 
input under which the transition is to be taken. The default is “true” 
(i.e., the transition is taken regardless of input data; see below for more 
details).

• -cntval integer – specifies that if this transition is taken, the counter is 
loaded with the given value. Only valid when a counter is instrumented.
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• -cnten – when this flag is given, the counter is decremented by 1 during 
this transition. Only valid when a counter is instrumented.

• -trigger – when this flag is given, a trigger occurs during this transition. 

The order in which the transitions are added is important. In each state, the 
first transition condition that matches the current data is taken and any 
subsequent transitions in the list that match the current data are ignored.

Conditions

The conditions are specified using Boolean expressions comprised of 
variables and operators. The available variables are:

• c0,... cn, where n is the number of trigger conditions instrumented. 
These variables represent the output bit of the respective trigger condi-
tion.

• titriggerInID – the ID (0 thru 7) of an external trigger input. 

• cntnull – true whenever the counter is equal to 0 (only available when a 
counter is instrumented).

• iiceID – variable used with cross triggering to define the source IICE units 
to be included in the equation for the destination IICE trigger.

Operators are:

• Negation: not, !, ~

• AND operators: and, &&, &

• OR operators: or, ||, |

• XOR operators: xor, ^

• NOR operators: nor, ~|

• NAND operators: nand, ~&

• XNOR operators: xnor, ~^

• Equivalence operators: ==, =

• Constants: 0, false, OFF, 1, true, ON

Parentheses ‘(‘, ‘)’ are recommended whenever the operator precedence is in 
question. Use the Identify debugger statemachine info command to verify the 
conditions specified.
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For example, valid expression examples are: 

"c0 and c1" 

"!(c1 or c2) and c3"

"c0 or ti4" (condition c0 or external trigger ID ti4)

Other Subcommands

The Identify debugger statemachine clear command deletes all transitions from 
the states given in the argument, or from all states if the argument -all is 
specified.

The Identify debugger statemachine info command prints the current state 
machine settings for the states given in the argument, or for the entire state 
machine, if the option -all is specified. If the option -raw is given, the informa-
tion is returned in a machine processible form.

State Machine Examples

To implement a trigger behavior that triggers when the pattern on condition 1 
or condition 2 (c1 or c2) becomes true for the 10th time (a setting identical to 
counter mode events in the simple mode triggering), the following state 
machine can be used:

statemachine addtrans -from 0 -to 1 -cntval 9
statemachine addtrans -from 1 -cond "(c1 | c2) & cntnull" -trigger
statemachine addtrans -from 1 -cond "c1 or c2" -cnten

A trigger condition requiring pattern c2 to occur 10 times after pattern c1 has 
occurred, without pattern c3 occurring in between (commonly available in 
logic analyzers as “Pattern 1 followed by Pattern 2 before Pattern 3”) can be 
achieved with the following state machine:

statemachine addtrans -from 0 -to 1 -cond c1 -cntval 9
statemachine addtrans -from 1 -cond "c2 & cntnull" -trigger
statemachine addtrans -from 1 -to 0 -cond c3
statemachine addtrans -from 1 -cond "c2" -cnten

These behaviors can be cascaded by moving on to the next behavior instead 
of triggering in the transition that has -trigger specified, as long as there are 
trigger conditions and states available.



State Machine Triggering Chapter 8: IICE Hardware Description

Identify Actel Edition User Guide Copyright © 2011 Synopsys, Inc.
March 2011 123

Convenience Functions

There are a number of convenience functions to set up complex triggers avail-
able in the file identifyInstallDir/share/contrib/syn_trigger_utils.tcl which is loaded into 
the Identify debugger at startup:

• st_events condition integer – Sets up the state machine to mimic counter 
mode events of the simple triggering mode as described above. The 
argument condition is a boolean equation setting up the condition, and 
integer is the counter value.

• st_watchdog condition integer – Same as st_events for watchdog mode.

• st_cycles condition integer – Same as above for cycles mode.

• st_pulsewidth condition integer – Same as above for pulsewidth mode

• st_B_after_A conditionA conditionB [integer:=1] – Sets up a trigger mode to 
trigger if conditionB becomes true anytime after conditionA became true. 
The optional integer argument defaults to 1 and denotes how many 
times conditionB must become true in order to trigger.

• st_B_after_A_before_C conditionA conditionB conditionC [integer:=1] – Sets up a 
trigger mode to trigger if conditionB becomes true after conditionA 
becomes true, but without an intervening conditionC becoming true 
(same as the second example above). The optional integer argument 
defaults to 1 and denotes how many times conditionB must become true 
without seeing conditionC in order to trigger.

• st_snapshot_fill condition [integer] – Uses qualified sampling to sample data 
until sample buffer is full. The argument condition is a boolean equation 
defining the trigger condition, and integer is the number of samples to 
take with each occurrence of the trigger (default 1).

• st_snapshot_intr condition [integer] – Uses qualified sampling to sample data 
until manually interrupted by an Identify debugger stop command. The 
argument condition is a boolean equation defining the trigger condition 
and integer is the number of samples to take with each occurrence of the 
trigger (default 1).

Please refer to the file syn_trigger_utils.tcl mentioned above for the implementa-
tion of these trigger modes using the Identify debugger statemachine command. 
Users can add their own convenience functions by following the examples in 
the file.
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Cross Triggering with State Machines

Cross triggering allows a specific IICE unit to be triggered by one or more IICE 
units in combination with its own internal trigger conditions. The IICE being 
triggered is referred to as the “destination” IICE; the other IICE units are 
referred to as the “source” IICE units. 

Multiple IICE designs allow triggering and sampling of signals from different 
clock domains. With an asynchronous design, a separate IICE unit can be 
assigned to each clock domain, triggers can be set on signals within each 
IICE unit, and then the IICE units scheduled to trigger each other on a user-
defined sequence using cross triggering. In this configuration, each IICE unit 
is independent and can have unique IICE parameter settings including 
sample depth, sample/trigger options, and clock and sample clock edges.

Cross triggering is supported in all three IICE controller configurations 
(simple, complex counter, and state-machine triggering) and all three config-
urations make use of state machines.

Cross triggering is enabled in the Identify instrumentor (cross triggering can 
be selectively disabled in the Identify debugger). To enable a destination IICE 
unit to accept a trigger from a source IICE unit, enter the following command 
in the Identify instrumentor console window (by default, cross triggering is 
disabled):

iice controller -crosstrigger 1

For cross triggering to function correctly, the destination and the contributing 
source IICE units must be instrumented by selecting breakpoints and watch-
points. Concurrently run these units either by selecting the individual IICE 
units and clicking the RUN button in the Identify debugger project view or by 
entering one of the following commands in the Identify debugger console 
window:

run -iice all

run -iice {iiceID1 iiceID2 ... iiceIDn}

When simple- or complex-counter triggering is selected in the destination 
IICE controller, the following Identify debugger cross-trigger commands are 
available.

• The following Identify debugger command causes the destination IICE to 
trigger normally (the triggers from source IICE units are ignored).

iice controller -crosstriggermode DISABLED
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• The following Identify debugger command causes the destination IICE to 
trigger when any source IICE triggers or on its own internal trigger.

iice controller -crosstriggermode ANY

• The following Identify debugger command causes the destination IICE to 
trigger when all source IICE units and the destination IICE unit have 
triggered in any order.

iice controller -crosstriggermode ALL

• The following Identify debugger commands cause the destination IICE to 
trigger after the source IICE unit triggers coincident with the next desti-
nation IICE internal trigger.

iice controller -crosstriggermode after -crosstriggeriice iiceID
iice controller -crosstriggermode after -crosstriggeriice all

The first Identify debugger command uses a single source IICE unit 
(iiceID), and the second Identify debugger command requires all source 
IICE units to trigger.

When state-machine triggering is selected, the state machine must be speci-
fied with at least three states (three states are required for certain triggering 
conditions, for example, when the destination IICE is in Cycles mode and you 
want to configure the destination IICE to trigger after another (source) IICE.

With state-machine triggering, the following Identify debugger statemachine 
command sequences are available in the Identify debugger console window:

• The following Identify debugger command sequence is equivalent to 
disabling cross triggering. The destination IICE triggers on its own 
internal trigger condition (c0).

statemachine clear -all
statemachine addtrans -from 0 -cond "c0" -trigger

• In the following Identify debugger command sequence, the destination 
IICE waits for iiceID to trigger and then triggers on its own internal 
trigger condition (c0). This sequence implements the “after iiceID” 
functionality of the simple- and complex-counter triggering modes.

statemachine clear -all
statemachine addtrans -from 0 -to 1 -cond "iiceID"
statemachine addtrans -from 1 -to 0 -cond "c0" -trigger
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• In the following Identify debugger command sequence, the destination 
IICE triggers when the last running IICE triggers.

statemachine clear -all
statemachine addtrans -from 0 -cond "c0 and iiceID and iiceID1 

and iiceID2" -trigger
statemachine addtrans -from 0 -to 1 -cond "c0"
statemachine addtrans -from 1 -to 0 -cond "iiceID and iiceID1 

and iiceID2" -trigger

• In the following Identify debugger command sequence, the destination 
IICE waits for all the other running source IICE units to trigger and then 
triggers on its own internal trigger condition (c0).

statemachine clear -all
statemachine addtrans -from 0 -to 1 -cond "iiceID and iiceID1 

and iiceID2"
statemachine addtrans -from 1 -cond "c0" -trigger"

The incorporation of a counter in the state-machine configuration is similar 
to the use of a counter in non-cross trigger mode for a state machine.

State-Machine Editor
The Identify debugger includes a graphical state-machine editor that is avail-
able when state-machine triggering is enabled for the active IICE unit on the 
IICE Controller tab in the Identify instrumentor. 

To bring up the state-machine editor in the Identify debugger, click 
the Configure Statemachine Trigger icon in the Identify debugger toolbar. 
Note that the icon will be grayed out if state-machine triggering was 

not enabled in the Identify instrumentor when the design was instrumented 
and that an error message will be generated if more than 10 states are 
defined. Clicking the icon displays the Statemachine Editor dialog box for the 
selected IICE. 
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Each state is defined in an individual entry field. Within each entry, you can 
add multiple definitions for transitioning from that state. Each transition 
includes either one or two actions and a condition. The actions and condi-
tions are defined in the following tables.

Action Description

Decrement Counter Decrements counter when condition is true 
(mutually exclusive with Initialize Counter)

Initialize Counter Initializes counter to count specified by 
statemachine transition editor (mutually exclusive 
with Decrement Counter)

Trigger Sample 
Buffer

Triggers sample buffer when condition is true

Go to State Transitions to specified state when condition is true
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To use the dialog box:

• As an optional starting point, use Insert Macro to select predefined state-
machine behaviors from the drop-down list. When a macro is selected, a 
corresponding Configure Statemachine Macro dialog box is displayed to set 
the parameters for the macro. The following figure shows the dialog box 
for the st_B_after_A macro.

Enter the required parameters into the dialog box. These parameters 
include events, Boolean functions, transition count, and IICE unit. Click 
OK after all of the parameters are entered.

Condition Description

c0 ... cN References trigger event in active IICE unit 

cntnull True when counter is equal to 0 (available only when 
counter is instrumented)

iiceID References trigger event from second IICE unit for 
cross triggering (cross triggering must have been 
enabled when the design was instrumented)

titriggerInID References external trigger originating from an IICE 
module in another FPGA or on-board external logic

Boolean Boolean operators used to define state-machine 
events (see Conditions, on page 121)
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• Use the Add new transition, Edit current transition, and Delete current transition 
icons as required. The Add new transition and Edit current transition icons 
bring up the Statemachine transition editor dialog box which allows transi-
tions to be defined or redefined.

Click OK when the transition has been defined/redefined.

• Click OK in the initial Statemachine Editor dialog box when the state-
machine triggering condition has been defined.

Note that you can view the corresponding state-machine commands in the 
Identify debugger console window using the statemachine info -all command.
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State-Machine Examples
The Identify state-machine triggering feature allows the creation of counter-
based, state machines from sequences of trigger conditions to create very 
effective triggers.

You can set up a state-machine trigger during instrumentation and then 
program the state machine dynamically during debug to create a complex, 
design-specific trigger.

Building a Complex State-machine Trigger

When building a complex, state-machine trigger, you specify the number of 
trigger states, the trigger conditions (which can be set dynamically in the 
Identify debugger), and the counter width. A common design configuration is 
to trigger when a specific sequence of events occurs which, in turn, causes 
data collection to stop and the sample data to be downloaded by the corre-
sponding Identify debugger executable from the FPGA. You can enable state-
machine triggering and specify the states through the user interface as 
outlined in the following steps:

1. In the Identify instrumentor graphical user interface, select 
Actions->Configure IICE from the top menu bar or click the IICE icon.

2. From the Identify instrumentor Configure IICE dialog box, select the IICE 
Controller tab, click the State Machine triggering radio button, and specify the 
number of trigger states, trigger conditions, and the counter width in the 
corresponding fields.
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3. Build the state machine trigger from the Identify debugger console 
window. The following Identify debugger command sequence is an 
example.

statemachine addtrans -from 0 -to 1 -cond c0 -cntval 7 -trigger
statemachine addtrans -from 1 -to 0 -cond "cntnull"
statemachine addtrans -from 1 -to 1 -cnten -trigger 

Note that in the last Identify debugger statemachine command, the -to 1 
can be omitted (unnecessay because there is no change in state) and 
that because the -from states are the same in the second and third 
commands, execution falls through to the third command when the 
second condition is not true.

4. Once the state-machine trigger is created, use the Identify debugger 
statemachine info -all command to display and review the state-machine 
transitions.

The state-machine editor in the Identify debugger GUI can be used to define 
the state-machine trigger event described in step 3 as shown in the following 
figure.

load counter

trigger when counter = 0
count

transition on counter = 0

transition
count = 0

count > 0

transition
c0 = 1

load counter

trigger 
count = 0

State 0

State 1
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The following figure shows the state-machine transition editor (click the Add 
new transition icon).

The Identify debugger state-machine and state-machine transition editors 
allow: 

• Graphical entry of state machines 

• Editing of state transitions and trigger events

• Conditions to be combined with each other or with a counter

• Counter mode selection of up, down, or initialized to any value

State-machine Triggering with Tcl Commands

The IICE can be configured using TCL commands entered from both the 
Identify instrumentor and Identify debugger console windows. Some of the 
example commands are as follows: 

• To delete the state transitions from each IICE, use the following Identify 
debugger command:

statemachine clear -iice all
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• To enable complex counter triggering, use the following Identify instru-
mentor command:

iice controller complex 

• To set the counter width, use the following Identify instrumentor 
command: 

iice controller -counterwidth 8

• To configure an IICE for state-machine triggering, use the following 
Identify instrumentor command sequence:

iice controller -iice IICE statemachine 
iice controller -iice IICE -counterwidth 4 
iice controller -iice IICE -triggerconditions 2 
iice controller -iice IICE -triggerstates 2 

In addition to state-machine triggering, the above Identify instrumentor 
commands set the number of trigger conditions to 2 and the number of 
trigger states to 2. 

• To enable cross triggering, use the following Identify instrumentor 
command:

iice controller -crosstrigger 1 

• Similarly, to configure the sample depth, use the following Identify 
instrumentor command: 

iice sampler -depth 2048

Note that the only option for buffer type is behavioral.

Qualified Sampling

During qualified sampling, data is sampled on every clock. The following 
example uses qualified sampling to examine the data for a given number of 
clock cycles. To create a complex trigger event to perform qualified sampling:

1. From the Configure IICE dialog box in the Identify instrumentor GUI, 
select the IICE Controller tab, click the State Machine triggering radio button, 
and enter a value in the Counter width field to define the width of the 
sample buffer.

2. Select the IICE Sampler tab and enable the Allow qualified sampling check 
box.
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3. From the Identify debugger GUI, select qualified_fill from the Sample Mode 
drop-down menu.

4. From the Identify debugger GUI, click on the adjacent Configure 
Statemachine Trigger icon and define the state-machine trigger event. 

5. From the Identify debugger GUI, select the st_snapshot_fill macro from the 
Insert Macro drop-down menu.

Enter the trigger event (the condition that will be the qualifying trigger) 
in field A, enter the number of samples to be accumulated in the sample 
buffer after the trigger event occurs in field N, and click OK to update the 
state-machine definition.

When you click Run in the Identify debugger project window, the sample 
buffer begins accumulating data when the trigger event occurs and stops 
accumulating data after the specified number of samples is reached.
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Note: If you use the Identify debugger st_snapshot_intr macro in place of the 
st_snapshot_fill macro, the sample buffer is continually overwritten 
until manually interrupted by a stop command.

You can also perform qualified sampling using equivalent Identify debugger 
Tcl commands. The following Identify debugger example command sequence 
samples the data every N cycles beginning with the first trigger event.

iice sampler -samplemode qualified_fill
statemachine clear -iice IICE -all
statemachine addtrans -iice IICE -from 0 -to 1 

-cond "true" -cntval 0

statemachine addtrans -iice IICE -from 1 -to 2 
-cond "c0" -cntval 15 -trigger

statemachine addtrans -iice IICE -from 2 -to 2 
-cond "! cntnull" -cnten

statemachine addtrans -iice IICE -from 2 -to 2 
-cond "cntnull" -cntval 15 -trigger

Remote Triggering

Remote triggering allows one debugger executable to send a software trigger 
event to terminate data collection in the other debugger executables, effec-
tively creating a remote stop button.

You can selectively set the remote trigger to:

• trigger all IICEs in all debugger executables

• trigger all IICEs in a specific debugger executable

• trigger a specific IICE in a specific debugger executable

A common design configuration is to trigger all FPGAs on a single board-level 
event; when that event occurs, data collection is stopped and the sample data 
is downloaded by the corresponding debugger executables for all FPGAs.

Remote triggering is a scripting application. The IICE/debugger targets are 
defined by the Identify debugger remote_trigger command (see the command 
description in the Reference Manual). 
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As an example, the Identify debugger scripting sequence 

run ; remote_trigger -pid 12

waits for the trigger condition in the active IICE and then sends a trigger to all 
IICE units in the debugger executable identified by processID 12.

Importing External Triggers

An import external trigger capability can be used with trigger signals origi-
nating from on-board logic external to the FPGA or from an IICE module in a 
second FPGA. For information on using this feature with state-machine 
triggering, see the Importing External Triggers application note available on 
SolvNet.
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C H A P T E R  9

Connecting to the Target System

This chapter describes methods to connect the Identify debugger to the target 
hardware system. The programmable device or devices in the target system 
that contain the design to be debugged are usually placed on a printed circuit 
board along with a number of other support devices. The difficulty is that the 
boards differ greatly in the connections between their programmable devices, 
the other components, and the external connections of the boards. 

This chapter outlines how to connect the Identify debugger to most of the 
common board configurations. and addresses the following topics:

• Basic Communication Connection

• JTAG Communication

• JTAG Hardware in Instrumented Designs

• Using the Built-in JTAG Port

• Using the Synopsys FPGA Debug Port

• JTAG Communication Debugging
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Basic Communication Connection
The components that make up the debugging system are:

• The host machine running the Identify tool set with a loaded project. 

• The communication cable connecting the host machine to the program-
mable device.

• The programmable device or devices loaded with the instrumented 
version of the design to be debugged.

Identify Debugger Communications Settings
Identify debugger communications settings are defined on the project window 
by selecting the cable type from the drop-down menu.

Cable Type

The cable type is selected from a drop-down menu in the Communications 
settings area of the Identify debugger project window (see following figure). 

The Actel_BuiltinJTAG cable type supports the Actel flashPro, flashProLite, and 
flashPro3 cables. If you are using the command interface, set the com 
command’s cabletype option to Actel_BuiltinJTAG (or demo). 

Demo Cable Settings

The Port Settings button is disabled when the demo cable is selected.
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Identify Debugger Configuration
All parts of the debugging system must be configured correctly to make a 
successful connection between the Identify debugger and the instrumented 
device or devices through the cable. In addition to selecting the cable type 
and port parameters described in Identify Debugger Communications Settings, 
on page 138, the following additional requirements must be met to ensure 
proper communications.

Parallel/USB Port Drivers 

The parallel port or USB driver must be installed and operating (see the 
installation procedures in the release notes). Make sure the host machine on 
which you are running the Identify debugger has the parallel port or USB 
driver installed. 

Communication Cable Connections 

The communication cable must be connected correctly. There are two 
connections:

• Cable-to-host – make sure that the parallel port you connect the cable to 
corresponds to the lpt specified using the com port command. 

The Identify debugger uses the “standard” I/O port definitions: lpt1: 
0x378-0x37B, lpt2: 0x278-0x27B, lpt3: 0x3BC-0x3BF, and lpt4: 0x288-
0x28B if it cannot determine the proper definitions from the operating 
system. If the hardware address for your parallel port does not match 
the addresses for lpt1 through lpt4, you can use the setsys set command 
variable lpt_address to set the hardware port address (for example, setsys 
set lpt_address 0x0378 defines port lpt1).

• Cable-to-board – the cable must be connected correctly to the board that 
contains the programmable device to be debugged. Also, during instru-
mentation you selected a JTAG connection to use: builtin or Synopsys 
FPGA debug port (soft). If you select the builtin option, connect the cable to 
the same leads that you use for the JTAG based programming of the 
chip. If you select the Synopsys FPGA debug port (soft), four JTAG 
signals are added to the top level of your design. You must assign these 
signals to pins on the chip that are connected to accessible probe points 
on your board. Once this is complete, connect the four JTAG signals to 
the proper probe points, and make sure that you also connect the power 
and ground leads.
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JTAG Chain Description

If you are using the builtin JTAG connection and the device to be debugged is 
part of a multi-device scan chain, the Identify debugger first attempts to 
detect the devices in the scan chain. If auto-detection is unsuccessful, you 
must describe the device chain to the Identify debugger using the chain 
command. 

Chip Programming 

Make sure that you program the device with the instrumented version of your 
design, NOT the original version. 
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JTAG Communication
JTAG is a 4-wire communication protocol defined by the IEEE 1149.1 
standard. The JTAG standard defines the names of the four connections as: 
TCK, TMS, TDI, and TDO. 

The JTAG compliant devices can be connected to a host computer through a 
JTAG cable. Such devices can be connected directly to the cable (see following 
figure), or multiple devices can be connected in a serial chain as shown in the 
figure on the following page.

Notice in the second figure that the TCK and TMS connections are connected 
directly to both devices while the TDI and TDO connections route from one 
device to the other and loop back to the JTAG cable.
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TDO

TAP
ControlTDI
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JTAG Hardware in Instrumented Designs
The Identify tool set uses a JTAG connection to communicate with the instru-
mented design. To do this, the IICE must contain a TAP controller that imple-
ments the JTAG standard. The IICE JTAG connection currently can be imple-
mented in one of two ways:

• The IICE can be configured (using the builtin option) to use the JTAG 
controller that is built into the programmable chip. This approach has 
the advantage that the built-in TAP controller already has hard-wired 
connections and four dedicated pins. Accordingly, employing the 
Identify tool set does not cost extra pins. In addition, the built-in TAP 
controller does not require any user logic resources because it usually is 
implemented in hard-wired logic on the chip. Unfortunately, not all 
devices have a usable built-in TAP controller. 

• The IICE can be configured (using the soft JTAG port option) to include a 
complete JTAG compliant TAP controller. The TAP controller is 
connected to external signals by using four standard I/O pins on the 
programmable device. Any programmable device family can utilize this 
type of cable connection since it only requires four standard I/O pins.

The following sections provide more detail on these two communication 
options.

Using the Built-in JTAG Port
Some programmable device families employ a built-in TAP controller as a 
means for device configuration. In most cases, the IICE also can be config-
ured to use this built-in TAP controller. Using this TAP controller saves the 
user logic necessary to implement the controller and also saves four I/O pins.

Using the built-in port is slightly more complicated than using the Identify 
debug port because the built-in port usually has special board-level connec-
tions that facilitate the programming of the chip. Consequently, these 
programming connections must be understood to properly connect the JTAG 
cable to the board and to properly communicate with the IICE.
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Boards with Direct JTAG Connections

HAPS boards and other boards that connect the built-in JTAG port directly to 
four header pins on the board allow the JTAG cable to simply be connected 
directly to the header pins. This configuration works for both directly 
connected devices and serially chained devices.

A common serial configuration is the combination of an EEPROM with a 
programmable device. This configuration allows you to either directly 
program the chip, or to program the EEPROM and then use the contents of 
the EEPROM to program the device via some other connection (see following 
figure).

This configuration is well suited to the Identify debugger and works just like 
any other serially connected chain.

Similarily, when using the Identify tool set with a HAPS board in a multi-
FPGA environment, the design is distributed among the FPGAs and the 
instrumented logic is included in one or more of the FPGAs. In this configura-
tion, the IICE unit or units in each FPGA are individually accessed to provide 
the required debugging capabilities for their associated portion of the design 
logic.
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Using the Synopsys FPGA Debug Port
By configuring the IICE using the soft JTAG port option, the design instrumen-
tation includes a complete JTAG-compliant TAP controller. The Identify 
debugger connects the TAP controller to four top-level I/O connections to the 
design. The signal names for these connections are:

• identify_jtag_tck: the asynchronous clock signal

• identify_jtag_tms: the control signal

• identify_jtag_tdi: the serial data IN signal

• identify_jtag_tdo: the serial data OUT signal

Direct JTAG Connection

Commonly, the host computer is directly connected to the four JTAG signals 
on the programmable chip in this way:

• The four JTAG I/O signals on the programmable chip are connected to a 
header on the circuit board that contains the programmable chip.

• A standard JTAG cable is connected to the four pins on the circuit board 
header.

• The other end of the JTAG cable is connected to the host computer. 
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Serial JTAG Connection

A programmable chip using the Synopsys FPGA Debug Port can also be 
connected in a serial chain. To allow the Identify debugger to communicate 
with the device, the configuration of the device chain must be successfully 
auto-detected or declared using the chain command (see the Reference 
Manual). 

The steps for making a serial cable connection are the same as a direct cable 
connection described above.

JTAG Clock Considerations

The JTAG clock signal syn_tck on the Identify JTAG port drives many flip-flops 
in the instrumentation logic – the number depends on the instrumentation, 
but can be larger than 1000 flip-flops. Consequently, the clock signal on the 
programmable device must be able to drive large numbers of flip-flops and 
have low-skew properties. If the JTAG clock signal is not handled correctly, it 
is likely that the instrumentation will act erratically. 

Most programmable devices have the ability to route such high-fanout 
signals using dedicated clock drivers and global clock distribution networks. 
Different devices use different methods of accomplishing this and have 
different names for this resource. Here are some simple guides:

• Some programmable devices have a number of dedicated clock I/O pins 
that drive internal clock distribution networks. In this case, be sure to 
connect the syn_tck signal to the chip using one of these clock I/O pins.

• Other programmable devices have clock buffers and clock distribution 
networks that can use any internal signal as a clock signal. For these 
technologies, the synthesis tool usually detects high-fanout signals and 
implements them with a clock buffer. In this case, it is important to 
make sure that the synthesis tool has worked correctly. If it does not put 
the syn_tck into a global buffer, you may need to manually specify that it 
do so.
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Boards Without Direct Built-in JTAG Connections
Some boards are designed so that the built-in JTAG port cannot be reached 
from pins on the board. For example, a board may connect an EEPROM 
directly to the built-in JTAG port on the programmable device. The EEPROM 
is directly programmable from the JTAG connection (see following figure).

In this case, the only connection that allows the Identify debugger to talk to 
the programmable device is a soft JTAG Port. This configuration requires a 
second JTAG cable to directly connect to the four I/O pins on the program-
mable device as shown in the following figure.
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JTAG Communication Debugging
The Identify debugger performs a number of diagnostic communication tests. 
The first time the Identify debugger connects to the on-chip TAP controller, it 
performs extensive communication tests. Later, every time the “run” function 
is executed, either by clicking the Run button or executing the run command, 
simpler and faster tests are executed. 

Below is a list of communication related error messages with some additional 
explanations.

Basic Communication Test
This test sends a pattern of ones and zeros to the chip and examines the 
return values

• ERROR: Communication is stuck at zero. Please check the cable connection.
It is likely that the Identify debugger is unable to communicate with the 
instrumented chip. This error is usually a cable connection problem, or 
the cable type is not set correctly.

• ERROR: Communication is stuck at one. Please check the cable connection.
This has the same reasons as a stuck-at-zero communication error.

• ERROR: Communication is returning incorrect IR data. Please check the cable 
connection.
If this error is received, then the previous two errors were NOT received 
as the communication is returning a mixture of ones and zeroes. 
However, the data is not coherent and again the communication connec-
tion is suspect.

• ERROR: Communication problem - data sent is not the same as data received.
This test verifies that the Identify debugger can shift data into the 
instrumented chip and receive the same data back. If this error occurs, 
there is again a problem with your cable connection or the cable type 
setting is incorrect.

The last two errors can also be the result of a syn_tck signal that is not using a 
high-fanout clock buffer resource, and thus may show large clock skew 
properties. If you are using a parallel port, make sure that you have selected 
the correct port.
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On-chip Identification Register
The Identify instrumentor adds hardware to implement an on-chip Identifica-
tion Register.

• ERROR: Cannot find valid instrumented design.
The Identify debugger cannot verify that the identification register on the 
instrumented design is correct or even exists. This error usually means 
that the design on the programmable chip is NOT the instrumented 
version of the design. 

• ERROR: Instrumented design on FPGA differs from design loaded into Identify 
Debugger.
The Identify debugger verified that the chip is instrumented but the 
instrumentation does not match the project that was loaded into the 
Identify debugger.

JTAG Chain Tests
The Identify debugger attempts to verify the device chain (as defined by the 
chain auto-detector or the chain command).

• ERROR: No hardware devices were found. Please check the cable connection.
No devices can be seen in the JTAG identification register chain. 
Probably a bad cable connection, or the cable type is incorrect.

• ERROR: The actual number of devices differs from the defined number: ACTUAL: XX 
DEFINED: YY
The number of devices seen in the JTAG chain is XX, but the Identify 
debugger was expecting the number to be YY (as was defined using the 
chain command). The chain description is incorrect.

• ERROR: The actual IR chain size differs from the defined size: ACTUAL: XX 
DEFINED: YY
The total number of JTAG identification register bits is incorrect. The 
Identify debugger measured the hardware to have XX bits, but was 
expecting YY bits (as was defined using the chain command). Please 
review your chain configuration.
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• ERROR: Communication with device number XX is not correct. Please check your 
chain setup.
If this error appears, the previous error does not appear. Thus, the total 
JTAG instruction register length is correct, but the size of the instruc-
tion register of device number XX is incorrect. It is likely that the order 
of your devices is incorrect. Review your chain settings.
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